Can't import DXF from Fusion 360


(Reiner) #1

I am trying to import a DXF that I saved in Fusion 360 into Carbide Create 304 but after I select the file, I get a screen where size is 0 and number of elements is also 0. If I look at the DXF in IrfanView, it does have drawing elements. Do I need special options to import my file?Tray.dxf (4.1 KB)


(William Adams) #2

More likely you need to reopen the DXF and then re-export it w/ settings which Fusion 360 will accept.


(Reiner) #3

The DXF was created in Fusion. I want to import it into Carbide Create.


(William Adams) #4

Okay. For that, some of these notes / procedures may apply:

  • it may help to use the OVERKILL command to eliminate any overlapping or intersecting paths before exporting from AUTOCAD
  • AutoCAD 2000 DXF format (model geometry only, base model scaling) export from the desired face (not isometric view)
  • 2004 Lines

I’d thought that there was some discussion of this in the past, but can’t find it.


(Carl Hilinski) #5

I hate when people don’t answer the original question, but I just have to ask: why do you want to import it into Carbide Create?


(Reiner) #6

I wanted to create the tool path in Carbite Create. I just start with my SO3 and I was not able to create the shape in Carbite Create (but could create it easily in Fusion 360 since I used it for my 3D printer too). The CAM module in Fusion seemed to be a too big first step for a beginner, so I thought I just import the DXF into Carbite Create and then do the tool path creation there.


(Carl Hilinski) #7

Can you tell me what I’m supposed to see. When I import the image, I see a large rectangle. Inside that is another rectangle with rounded corners. And then there’s a smaller rectangle in the center. I also looked at it with the online Autodesk viewer and I see the same thing.


(Reiner) #8

Yes, that is the full sketch from Fusion. That is also how I see it in my dxf viewer. I need the big rectangle with the rounded corners. The rest is (in Fusion) construction lines that shouldn’t be part of the export i.m.h.o.
The base shape is a rectangle with 280mm sides. The inner rectangle is a 100mm rectangle that is only used to define the center points for the 90mm radius arc segments that define the “filets”.
I have opened the DXF in Inkscape and removed the unneeded lines. Attached the result…Tray.dxf (5.8 KB)


(Carl Hilinski) #9

Will will show how this is done in CC, I’m sure. he’s very good about that.


(Reiner) #10

I think I figured it out in the meantime… the problem I got stuck with was that CC wouldn’t accept my inputs since it doesn’t like the 3 digits after the dot if you are working in mm even though it enters the numbers with three digits precision itself.
Seems to be a bug in CC I assume.


(William Adams) #11

Okay. I

  • opened this up in Inkscape
  • selected everything
  • Path | Combine
  • File | Document Properties | Resize Page to content…
  • Resize page to drawing or selection
  • Path | Stroke to Path
  • Path | Union
  • Path | Break Apart
  • select and delete the inner path copy
  • select the path
  • Path | Inset until it aligns against the page edge
  • File | Save As | SVG

A copy is attached here, but I’d suggest working through the steps — there are other ways to do this, but this is the easiest to explain / show / document.

Back when I was teaching folks how to use Freehand I’d have my undo stack set to 100 and would work through things such as this at full speed, then undo back to the beginning and then go through step-by-step what was done, explaining the whys of each step.


(Reiner) #12

Thanks Will!

BTW: Do you know if the strange behavior of CC when working with metric that I described above is a bug and if so, how to report it?


(William Adams) #13

Carbide Create will only allow 3 digits after a decimal — if zeros (or any other numerals) are already present, then they have to be deleted first. If it still won’t allow you to enter things, then that would be a bug (I actually feel that the current behavior is wrong / bug-like, but it seems to be intentional).

Bugs should be reported to support@carbide3d.com or beta@carbide3d.com (for betas)


(Reiner) #14

It seems that for metric, only two and in some entry fields even just one digit after the decimal is allowed but the program always formats numbers with three digits after the decimal. So I assume it is a bug and will report it.


(William Adams) #15

I dunno. I was just able to draw a rectangle in Imperial measure, then switch to metric, change the dimension to something.001, change back to Imperial, see a slightly different measurement, then switch back to metric and see the same something.001 — I suspect that you’re seeing some sort of rounding error, so do please report this w/ the specific values involved.

FWIW, my preference for this sort of thing is the approach taken by TeX — format according to some suitably small unit which perfectly divides into the measures which one needs and do all math internally using integers. No rounding.


(Neil Ferreri) #16

@reibuehl Fusion 360 CAM isn’t too bad once you’ve done it. Most of the settings don’t usually need to be modified. If you’re already modeling in Fusion 360, I think it’d be worth your time to get used to the CAM part. Ask if you need help.


(Kelly Taylor) #17

I believe 3 decimals is the limit of the GRBL driver in metric mode. I have written all of my cnc code to 3 decimal places because of GRBL limitation, so CC should have the same limit and so this would would not be a bug.


(Reiner) #18

I got the message from CC support that this could be related to incomplete localization of CC (decimal point vs. decimal comma). I still need to verify this but since I am not at home currently, this will not happen before late next week.


(Reiner) #19

My problem shows up with 3 digits precision - CC wants only 2 or sometimes even 1 digit precision in some fields.