Can't skip the Roughing Pass


(Scott) #1

I have Meshcam 7 (build 5) for Mac and I’ve made a first attempt at a job. I’m not convinced the finish pass worked. But the roughing is fine. Now if I try to do a finish pass and DISABLE the roughing pass in Toolpath Parameters, it doesn’t generate a pass at all (The finish types are all listed as 0 Minutes). If you run this on the CNC, it just prompts for the tool changes and spins up but there is no path.

This is basically the same as Only Rough Cut, No Finish Pass but I didn’t want to revive it.

So… before I fall too deep down this rabbit hole, this should be able to skip the roughing pass, right? To me, it just looks like it ONLY does the roughing pass.


(Scott) #2

Version 6 (Build 26) just crashes when I calculate a tool path.


(billyprops) #3

Just a guess, but it’s probably because you’re using the same size end mill for each operation. There’s no need to do anything after the roughing pass because the subsequent tool won’t be able to get into a smaller place.

Also, based on the shape of the part you’re cutting, you should only use ball mills.


(Scott) #4

This is what my first attempt looked like. I wanted to go smooth it up more and get rid of the scalloping.

I’ll try a smaller ball nose and see if that makes a difference!


(Scott) #5

Specifying different tools for roughing and finish, but then disabling the roughing pass… didn’t work. It still generates no finish path, just the tool change.


(William Adams) #6

Still learning MeshCAM myself, but I believe that you need to calculate both, then only export the operations which you want.


(Scott) #7

Yeah, that makes sense and it’s what I’m trying to do, but the paths are null. Here, I’m using a large tool for roughing and a smaller one for finish. There’s a calculation phase and then zero is generated for the other passes. It’s not even making paths for them, so I’m not sure what’s up.


(Scott) #8

So… after all this, I still can’t get a finish pass to happen at all and it’s ignoring these spots of my model, which created untouched islands.


(Scott) #9


(mikep) #10

I think you’ve got the surface angle limit set?


(Scott) #11

Actually, I think it’s related to the Max Depth. The bottom-most layer of the bowl shape is below the max depth, so it is ignoring it instead of clearing the wood above the line. (speculating)

Here, I set Max Depth to 1/4" (red horizontal grid line) and you can see it only machines the area up above 1/4".


(Scott) #12

But changing the Max Depth to 50% of the stock will create the hole again, as shown here:


(Scott) #13

And finally, if I change Max Depth to the full stock, the hole disappears and problem solved. Only problem is I can’t cut to this depth and it’s a flip job anyway.

Max Depth is the only setting changed here.


(Scott) #14

Sure enough, just nudging Max Depth down enough to cover all surfaces of the top got rid of the holes. I need to figure out an effective max cutting depth for 1.3" wood - without impacting the tool holder to stock edge and flip jig frame.


(Scott) #15

And back on the original topic, fixing this hole seems to address the lack of finishing pass as now there is a non-zero estimate: