Carbide motion automatic homing not a good idea


(William Adams) #61

To add to that, there is a nifty 3D machine simulator, GrblGru which may have the functionality you want — it was significant enough that it was added to the front page of the wiki: https://www.shapeoko.com/wiki


(Charley Yancey) #62

Mr. Adams-
As always, swift, thoughtful, and helpful replies.
.
HOWEVER, still having major issues trying to get RELIABLE communications to unit, as well as just about any CNC sender s/w which will work on cheap little win10 tablet. (Done lugging laptop out to shed, that is just too many issues all the way around.)
Have -I think- ‘tried’ just about every freebie sender s/w out there (installed java and python to do so, and STILL trying to track down necessary python libraries which evidently aren’t named what they once were), and have had only ONE which works with any consistency, and it is not 100%
Source Rabbit’s g-code sender will drop communications a handful of times when jogging to zero out, but is about the onliest program I can get to work at all. Others are either complaining about missing DLL’s (sigh), or python libs, or opens up okay, but won’t connect, or connects, but won’t control, etc, etc, etc.
Turns out, NOT the CNC, NOT the ArcCam s/w, NOT anything else, but simply getting the dog damn g-code off the dog damn tablet to the dog damn CNC has caused me more headaches than anything else.
IF I am not mistaken, I have downloaded grbl-gru as well, but it has some issue or another. (They are all blurring together at this point, have tried at least a dozen or more progs.)


(William Adams) #63

Please accept our apologies for your difficulty. Please review the suggestions at: https://www.shapeoko.com/wiki/index.php/Electronics#Recommendations — if that doesn’t help, let us know at support@carbide3d.com (mention what you’ve already tried) and we’ll sort out how to get you connecting and working reliably.


(Charley Yancey) #64
  1. don’t think you have to apologize for what are (in all probability) windows 10 and/or tablet issues (although some issues were prevalent with the laptop, with the EXCEPTION of CarbideMotion worked ok on laptop).
  2. Went to copy the notorious msvcp120/msvcr120.dll’s from the laptop to the tablet, and -first strike- win 10 on tablet was being difficult in letting me rename existing tablet DLLs to something like “msvcr120ORIGTAB.dll”, so could revert without too many issues, but bill gates does not like me doing that. grrrrr…
    I thought I bought a laptop and a tablet, but apparently it belongs to micro$oft and Hewlett Packard, and they occasionally let me do stuff I want to on their computers…
    grrrr…
    why is it I always feel like I/owner/master am being inconvenienced for the sake of the convenience of the computer/corporation/slave ? ? ? /sarc (I think)…

(Charley Yancey) #65

replying to myself, communication issues make TRYING to get a piece cut an exercise in futility… somehow got UGS to work, kinda/sorta/off and on, but couple issues make it not dependable, too:

  1. screen on tablet is so teeny tiny, have to use outermost electron of last atom on the last molecule of the tip of my finger to select commands/options, etc… fat fingered it just a minute ago where instead of hitting ‘reset to zero’, hit ‘return to zero’ button and it tried to dive into wood
  2. still have sporadic connection issues, maybe get through one SHORT job without disconnecting, but then fails to run next bit change without dropping connection… in this case, did one side of a pc of wood okay, then when flip it to do same pattern on other side, doesn’t connect, reboot, reconnect, re-zero, and go to send file JUST SENT successfully 5 mins before, and doesn’t budge… reboot, blah blah blah, resend, and starts to do first tool path, and then stops, no error msg, no nothing…
    all too typical: spend HOURS dicking around trying to figure out issues, and get 5-10 minutes cutting done maybe somewhat right…
    REALLY getting frustrated trying to get the simplest and shortest of projects done without dicking around with it for HOURS…