Carbide Motion Test/Beta


(Donavon Yelton) #61

FWIW, I gave up on getting CM to work on Ubuntu and Linux as a whole.


(David McMillan) #62

Well, crud. The utter silence from the C3D team on this isn’t encouraging, either.


(UltraMegaPhil) #63

I ran into this issue on my Ubuntu 16.04 machine. I had all the required qt packages installed, but for some reason they weren’t being picked up the QML import path. I dug around the file system a bit and it looks like (on my machine at least) the modules are installed at:

/usr/lib/x86_64-linux-gnu/qt5/qml

I basically found this directory by doing a cd / && find . name Qt* and looking for something that contained the hierarchy Qt/labs/settings/

Once I added this directory to the QML2_IMPORT_PATH environment variable I was able to run the CarbideMotion executable directly from the command line. I did this by adding the following line to my .bashrc file:

export QML2_IMPORT_PATH="/usr/lib/x86_64-linux-gnu/qt5/qml"

However, running from the Unity desktop still didn’t work, I needed to go into the carbidemotion.desktop file located at ~/.local/share/applications and change the Exec statement to include the environment variable as well, like this:

Exec=env QML2_IMPORT_PATH="/usr/lib/x86_64-linux-gnu/qt5/qml" /home/myuser/Apps/CarbideCreate/Carbid

After that everything seems to be working properly.

Hope this helps someone out there :slight_smile:


(benny) #64

Thanks @UltraMegaPhil, works like a charm like that.
It does say there is an update, which does not exist for linux.
Version 3.0.356, build 30/3/2016. So, you found any bugs with this version that are show stoppers and reason to use windows after all? H


(Edward Ford) #65

(Edward Ford) #66