Error (1) error in line 20: arc endpoint error?


(Griff Carpenter) #61

Thanks Rob. Now I need to try 411 with the “regular” F360 post processor for Carbide 3D machines.


(Serge Sozonoff) #62

Hi,

Is there a test build of 411 for OSX ?
Seems an official build has not been released yet.

Thanks,
Serge


(Luke) #63

I don’t believe so, I think it’s coming


(Evan Day) #64

Just following up on this. I had been running CM 410 for a little bit along with GRBL 1.1; no issues so far. I did get the arc endpoint error that started this thread using a toolpath from Fusion 360. I found this thread, updated to Build 411, and it did solve the problem. I did notice though that in 411, I get some bugs when jogging the machine but I can’t reproduce the exact conditions that cause the problem. Sometimes when jogging with either my miniature wireless Bluetooth keypad or just by using the mouse, CM seems to hang where I can click the buttons in jogging screen, but I can’t get the machine to respond. Sometimes it takes a complete restart of CM in order to fix the issue.

@robgrz, I know that 411 isn’t probably ready for full public consumption yet, so just wanted to note the behavior. I wish I had more data to give. I will start paying attention to see if I can point to certain conditions.


(Chris) #65

I encountered this error last night with CM v410, GRBL 1.1.

I went back into fusion and changed all my Arc points into Lines, then fillet the edges to create the same arc. Exported and it worked perfectly with no error. A quick fix if anyone is stuck.


(mikep) #66

Fixes the arc error, but breaks tool changes from “sort of broken” to totally broken on shapeoko.


(Stephen Kidwell) #67

How did you do that? I am getting this error and the job i am running couldnt be any easier…


(Chris) #68

I think what I did was a fluke and not repeatable.

I just downloaded CM 4.11 from the dropbox above and I haven’t seen that problem again.


(Chris F) #69

I upgraded to 4.11 two days ago and my Fusion 360 G-Code using the standard Carbide 3D Post Processor has been working fine since then. I always run each tool in a separate G-Code file, so I do not have much input on tool changes, but it handles the normal one at the beginning of the G-code just fine. I have run six or seven successful projects since the upgrade.


(Rob Grzesek) #70

In what way are they “totally broken” instead of “sort of broken”?

Also, FYI, we put up a beta page at http://carbide3d.com/carbidemotion/beta


(mikep) #71

For the Nomad, nothing seems to have changed. For the shapeoko though…
Prior:

When the machine got to the T command

  1. it would present the spindle and pause movement (like it does on the nomad)
  2. it would keep executing the command after, and the spindle would turn on (if you have a spindle switch set up)
    I’d call this “sort of broken” - you could still do a tool change, but you had to turn off the spindle manually, then turn it back on. If you had a way to set the tool length with a spacer, it could be made to work. I’ve made it work, anyway.

Now:
When the machine gets to the T command

  1. Nothing at all happens and it just blows right through it without presenting the spindle, pausing, or anything.
    I’d call this totally broken, you can’t do a tool change at all any more.

(mikep) #72

I went and tried this out again. It works in the previous “kinda broken” way with meshcam, but no longer moves the spindle front and center, which it used to. It still turns on the spindle instead of turning it off.