*FIXED* GRBL 1.1 CM4 jogging increment offset issues


(Zach Hodgson) #1

Hello,

I documented two issues I’m having with my machine.

Number 1 is the jogging increment offset issue. When I jog the spindle if say in a 1mm increment, the spindle will move 1mm, but the offset shows a fraction of that.

Number 2 I’m not sure how best to explain it, which is why I made the video, but when starting an operation the machine just takes off and I have to shut it off before it hits the end of the rails.

Any advice would be much appreciated.

Zach


(Luke) #2

If you are running CM 4.0 there have been a number of releases since - worth downloading that to fix the jog issues.


(Zach Hodgson) #3

I’m on 406, latest release


(Scott Conant) #4

Make sure you send a trouble ticket request to: beta@carbide3d.com


(Luke) #5

Interesting. When you go to mm and move the shapeoko by 1mm what happens?

On the 2nd issue/video what happens if you change project?

Did you load the s3 settings after the update?


(Zach Hodgson) #6

This is the config data. There are a few lines that aren’t correct. Do I fix that by just directly doing a command through the MDI?

Thanks, this is what it is currently at

(3706): <- ok
(3705): -> $132=80
(3704): <- ok
(3703): -> $131=465
(3702): <- ok
(3701): -> $130=425
(3700): <- ok
(3699): -> $122=400
(3698): <- ok
(3697): -> $121=400
(3696): <- ok
(3695): -> $120=400
(3694): <- ok
(3693): -> $112=5000
(3692): <- ok
(3691): -> $111=5000
(3690): <- ok
(3689): -> $110=5000
(3688): <- ok
(3687): -> $102=40
(3686): <- ok
(3685): -> $101=40
(3684): <- ok
(3683): -> $100=40
(3682): <- ok
(3681): -> $32=0
(3680): <- ok
(3679): -> $31=0
(3678): <- ok
(3677): -> $30=1000
(3676): <- ok
(3675): -> $27=5
(3674): <- ok
(3673): -> $26=25
(3672): <- ok
(3671): -> $25=1000
(3670): <- ok
(3669): -> $24=100
(3668): <- ok
(3667): -> $23=0
(3666): <- ok
(3665): -> $22=1
(3664): <- ok
(3663): -> $21=0
(3662): <- ok
(3661): -> $20=0
(3660): <- ok
(3659): -> $13=0
(3658): <- ok
(3657): -> $12=.01
(3656): <- ok
(3655): -> $11=.02
(3654): <- ok
(3653): -> $10=255
(3652): <- ok
(3651): -> $6=0
(3650): <- ok
(3649): -> $5=0
(3648): <- ok
(3647): -> $4=0
(3646): <- ok
(3645): -> $3=6
(3644): <- ok
(3643): -> $2=0
(3642): <- ok
(3641): -> $1=255
(3640): <- ok
(3639): -> $0=10


(Zach Hodgson) #7

It is missing $14=1

It is showing
$30=1000
$31=0
$32=0

Except those values aren’t in default grbl settings from here:
http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings

The rest are good.


(William Adams) #8

$14 for autostart is deprecated and now the only option. I’ve edited the article in question to reflect that.


(Zach Hodgson) #9

FIXED. I didn’t send config data after updating to 1.1.

After I clicked config data in the settings tab everything is working great