GRBL Error: Serial Port: ResourceError

(Dave Black) #21

Problem seems to be solved.
We received a new control board (version 2.4d) yesterday.
No problems showed up after installation of the new board.

(Mark Jurisch) #22

Your problem is solved… This problem is plaguing me. I’ve tried grounding all the components together, using a surge protector, powered usb port, shielded usb cable. I have ruined so much material with the machine randomly stopping in the middle of a job, even if the job is only a couple minutes long.

My controller version is 2.2, machine number 688. I feel like I’m being punished by having bought an early machine (pay to upgrade the z plate, pay to get wider belts, pay to get homing switches) I really want this machine to work well, but every time I have tried to use it since I bought it, its been nothing but frustration.

I sent an email to support but they just asked me to do the same things that are already listed in this thread and the links given earlier. I’m

(mark robinson) #23

Have you updated your ticket with support and informed them you tried everything in the links? its also not mandatory to pay for any upgrades,you do have a choice.

(William Adams) #24

Please re-read your e-mail from support.

As I understood it when it was typed up, you were asked to confirm that you had tried the things in that list which were reasonable for you to have tried, and that if that were the case, we’d have someone contact you and work things out.

(Mark Jurisch) #25

I have now, I guess my email was still open as I never hit send. I will admit I am impressed to get support on the weekend :slight_smile:

(Mark Jurisch) #26

Just wanted to update this post that support helped me get things straightened out. Not up and running again, but I think I’m pretty close.

(tom burtonwood) #27

this url ( ) is coming up as 404 not found.

i am running into a similar issue, can’t connect. i ran the hello world just fine last weekend - now i’m trying to get some work done and i’m getting the same error.

(William Adams) #28

We’ve been revamping our site. That is instead at:

I suspect you have a problem specifically w/ Carbide Motion or permissions if Chilipeppr works — hopefully we can have a developer contact you about this next week — until then, my suggestion would be to use Universal G-code Sender:

or bCNC or some other comm / control app.

(tom burtonwood) #29

i tried UGS it connected but as noted wouldn’t do anything beyond that.

i’ll look at bCNC.