Issues after re-flashing GRBL 0.9


(Dalton McKee) #1

Hello everyone,

I briefly tried GRBL 1.1 and Carbide Motion 4 today, but ended up reverting back to GRBL 0.9 and Carbide Motion 4. After re-flashing, the machine is not usable… It will not even complete a homing sequence. I was wondering if someone would share the .hex file and EEPROM file (if needed) for me to use. I have tried the hex file located at the link below:

http://carbide3d.com/files/grbl.hex

When the machine starts a homing sequence, the stepper motors have a nice harmonic noise associated with the rate of movement which is very slow. Almost like the steps per mm is incorrect. It will home the Z axis first, then the X axis which crashes into the side of the machine. I am at a loss on this one… Any help is much appreciated.


(William Adams) #2

Did you also reconfigure?

http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings
and
http://docs.carbide3d.com/article/67-shapeoko-3-limit-switch-installation


(Dalton McKee) #3

@WillAdams I finally figured this out probably the moment you were typing your reply. After I wrote out that the steps per mm were not correct I started to look more into the default GRBL settings. I am back up and running. Thanks!


(Stephen Needle) #4

Hi
I’m having the same problem described above but the links attached do not seem to work.
Can you advise please or maybe resend the link paths.#Many thanks


(William Adams) #5

The site is being updated and links have moved. Please try:


(Stephen Needle) #6

Hi Will
Thanks for sending this through, I’ve run through the process but still no joy.
I’m getting some operation but on sending the $h all it does is drop the z axis toward the machining surface very very slowly.


(William Adams) #7

If beginning homing results in Z-axis moving down, it’s most likely that you have that axis reversed.

Did you install the Z-axis plate upside down? (from the front, the static pulley should be on the left) — if that’s the case, please remove and reinstall flipped over.


(Stephen Needle) #8

No I have a Nomad Pro - sorry should a started with this information shouldn’t I


(William Adams) #9

Please check in with support@carbide3d.com for the proper defaults for a Nomad.


(Stephen Needle) #10

Ok so I’ve re installed carbide motion v3.0.366 and now I’m not even able to connect. Message says “cutter did not respond”.


(William Adams) #11

Please check in w/ support@carbide3d.com noting:

  • which version of CM/CC you have installed
  • whether or no you’ve updated Grbl from 0.9 to 1.1

a list of all the steps which you are trying, what happens at each one, and what you expect.


(Stephen Needle) #12

HI
I have sent an email to support but no response so far.

Ok so I’ve managed to reflash the GRBL to v1.1 using the updater and that was confirmed by the uploader as successful. But I’m getting the ‘door open’ message from Carbide Motion v4 when I try to jog, which I presume means I’ve got so somehow disconnect the door sensor?

Anyone out there who’s had the same problem?


(Wing Wong) #13

I’m in the same/similar boat:

  • Nomad 883 Pro (used)
  • Grbl was 0.9 version and got upgraded to 1.1f version
  • Running Carbide Motion: 4.0.407 ( going to give 408 a try )
  • Used Send Config and restarted the Nomad 883 Pro

Symptoms I’m seeing:

  • Home causes ringing and the carriage doesn’t move.
  • After a while, Carbide Motion errors on Door Error message(my model has no door latch/sensor)

Using Arduino Serial Monitor:

  • I can confirm that the firmware updated
  • I can pull the config settings
  • When I $H to home, I get an Alarm:9, which indicates unable to home.
  • When I $X to clear locks/errors and perform manual jogging, the carriage moves as expected( G91 G0 X5) and works for all three axis.
  • Attempts to home with $H still fail.

I’ll probably try to re-flash the board and upgrade to 409 and try again, but it’s weird that homing doesn’t work, but manual jog does.

My $$ output:

Grbl 1.1f [’$’ for help]
ok
$0=100
$1=255
$2=0
$3=1
$4=0
$5=0
$6=0
$10=3
$11=0.020
$12=0.010
$13=0
$20=0
$21=1
$22=1
$23=0
$24=100.000
$25=1000.000
$26=25
$27=5.000
$30=10000
$31=2000
$32=0
$100=200.000
$101=200.000
$102=200.000
$110=2600.000
$111=2600.000
$112=1270.000
$120=270.000
$121=270.000
$122=270.000
$130=250.000
$131=250.000
$132=100.000
ok


(William Adams) #14

Differences between your Grbl settings and what I understand to be the defaults:

$0=10 (step pulse, usec) — you have 100
$10=255 (status report mask:11111111) — you have 3

$30, $31, and $32 used to not be set

Please try changing $0 and $10 back to what were the defaults at Grbl 0.9 — don’t see a reason for them to change, and I believe that $10 could be responsible for the sort of behavior you’re seeing.


(Wing Wong) #15

Okay, I’ll try updating $10=255 and check out what the situation is with $30/$31/$32. $0=10 after I had done the push config, but it still had the issue, so I tried bumping it up. I’ll set it back to 10 and see how it goes.


(William Adams) #16

Probably 30,31, and 32 are new in 1.1


(Wing Wong) #17

Well 30,31,32 are the spindle speed controls. So the values there are valid.
I reflashed the firmware and set $0=10 and $10=255. Left $30,$31,$32 as-is.

Tried homing and still failed. Went back and did manual jogging and looked up the homing process for GRBL and realized that it homes Z first… and while looking at the Z-axis, it looks like it’s stuck. Doesn’t move freely and can’t move it up or down. So looks like my homing problem is due to the Z axis motor/movement being stuck. Unrelated to GRBL 0.9 / 1.1 so going to explore the Z-axis issue on my end.


(Stephen Needle) #18

Hi
I had a chat with Jorge and ran a few checks and he seemed to think it might be the Z limit switch.
With Carbide Motion software open if you press any of the limit switches it will give an error but my z limit switch doesn’t do anything.
I’m willing to give anything a go now though, very frustrating!

my settings are;
(192): <- ok
(191): -> $132=100
(190): <- ok
(189): -> $131=250
(188): <- ok
(187): -> $130=250
(186): <- ok
(185): -> $122=270
(184): <- ok
(183): -> $121=270
(182): <- ok
(181): -> $120=270
(180): <- ok
(179): -> $112=1270
(178): <- ok
(177): -> $111=2600
(176): <- ok
(175): -> $110=2600
(174): <- ok
(173): -> $102=200.0
(172): <- ok
(171): -> $101=200.0
(170): <- ok
(169): -> $100=200.0
(168): <- ok
(167): -> $32=0
(166): <- ok
(165): -> $31=2000
(164): <- ok
(163): -> $30=10000
(162): <- ok
(161): -> $27=5
(160): <- ok
(159): -> $26=25
(158): <- ok
(157): -> $25=1000
(156): <- ok
(155): -> $24=100
(154): <- ok
(153): -> $23=0
(152): <- ok
(151): -> $22=1
(150): <- ok
(149): -> $21=1
(148): <- ok
(147): -> $20=0
(146): <- ok
(145): -> $13=0
(144): <- ok
(143): -> $12=.01
(142): <- ok
(141): -> $11=.02
(140): <- ok
(139): -> $10=3
(138): <- ok
(137): -> $6=0
(136): <- ok
(135): -> $5=0
(134): <- ok
(133): -> $4=0
(132): <- ok
(131): -> $3=1
(130): <- ok
(129): -> $2=0
(128): <- ok
(127): -> $1=255
(126): <- ok
(125): -> $0=10

Oh forgot to say Jorge has very kindly shipped me a brand new CM board and a Z limit switch, expecting delivery tomorrow so will report back then. Hopefully it solves the issue but doesn’t necessarily answer the current problem.