Limit / Homing Switch Error Messages Shapeoko XL


(Don Sieburg) #1

Hello, my new Shapeoko XL ran the paper test OK. However whenever I tried to run my first project it would start at a random set points.
I assumed it had something to do with the limit switches not being set and followed the message threads to remedy that situation in Carbide Motion Settings by changing the “Shapeoko Has Homing” to “true” / Table X to 850 / Table Y to 430.
Now when I try to start something new, I cannot jog anywhere and a screen appears that says “Click to Begin Homing” Then it heads for the right - rear corner and the belt chatters as it is obviously lost until I get these messages.
GRBL Error: Serial Port: Resource Error -or-
GRBL Error: Serial Port: Device Not Error

Help please / where do I go from here?
Thank you.
Don


(mark robinson) #2

have you made any ajustments in GRBL? thru the mdi and the $$ command?

http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings

also have a look at these videos when you have a chance,very informative


(William Adams) #3

Either you have a switch plugged into the wrong connector, or you have a bad switch.

When you press a switch, a light will light up on the control board if it works — please check all three. If all three are good, then you need to get the order they’re plugged in correct. (of course if one or more is bad, please contact support@carbide3d.com and we’ll get you replacements)


NEWB Goin NUTZ! X = Y & Y= X
(Mark Walker) #4

If homing is enabled, before you can jog, it homes.

Homing works this way: head toward the limit switches until they are hit then grbl and CM know where the spindle is because it knows where the limit switches are (or supposed to be). Typically this is away and right and spindle all the way up. That should be where your limit switches are. http://docs.carbide3d.com/article/80-working-with-homing

It sounds like your machine is behaving as expected up until your limit switches get hit. If they are installed and working, then perhaps it is software configuration. Step 8 in the limit switch installation guide ($22=1): http://docs.carbide3d.com/article/67-shapeoko-3-limit-switch-installation


(Don Sieburg) #5

Yes, I “thought” I was doing the right thing to straighten out the random home settings I was getting.
I changed the statement: “Shapeoko Has Homing” to “true” / Table X to 850 / Table Y to 430.
Should I revert back to defaults as your instructions seem to indicate?
Thank you!
Don


(Don Sieburg) #6

My machine get to the right / rear and then just chatters as the belt is skipping. (not good I’m sure)
Thank you!
Don


(mark robinson) #7

At this point i would use the mdi/log and check all the setting and the ($22=1) @markwal was referring too and also look at wills nice picture of the wires and make sure yours matches aswell


(Don Sieburg) #8

Will, all 3 switches are working.
I am positive they are in the right order because when I unplug one the the light for the respective switch no longer turns on the light.
The jamb (chattering) occurs as soon as the Y axis hits home.
More suggestions please.
Don


(Don Sieburg) #9

Will & Mark,
With the machine off, I manually moved the gantry forward the the router head to the left. When I turned the system on and activated Carbide Motion and clicked “Begin Homing” I quickly pressed the Y switch and the gantry stopped moving immediately. When I pressed the X switch, the movement slowed considerably (not stopped) and made an odd groaning sound.
Does this help?
Thank you.
Don


(mark robinson) #10

Not to sure on the groaning Don, you may want to contact support@carbide3d.com
and get a ticket started that way if someone dosent give you a fix on here you will have support on the way.did you have a chance to look at your log? as desribed above you can also post the setting here for us to look at, but the graoning may big a bigger issue which may need support.
mabie have a look at the set screw. start with the x axis since that one seems to be the culprit and then check the others
http://community.carbide3d.com/uploads/default/original/2X/8/835cbd9de1bd1d1582db675b643d4673824cd94e.png


(Don Sieburg) #11

Mark & Will, I am very happy to report the problem seem


(Don Sieburg) #12

Mark & Will,

I am very happy to report that my problem seems to be resolved. I had installed the Y axis homing switch backwards so that it missed touching the back frame by perhaps 2mm and I never noticed that. After correcting the problem, the homing procedure appears to be perfect. They touch, stop immediately and back off those points by a few mm… does this sound normal?

I have attached a screen shot of the log. Please review and let me know if it looks correct for my Shapeoko XL. Also, please sent me a link for setting up the home position (starting point) for any job.

Thank you for your expert help!

Don


(William Adams) #13

Thanks for the thorough explanation — I’ll add that to the list of troubleshooting checks on the installation page.


(Jerry Gray) #14

Seems to be a common problem :slight_smile: Easy to not see cause the bracket is so close it actually trips it sometimes. Third person I know of.


(Don Sieburg) #15

The bracket is almost symmetrical! The information Will provided about the switch lights illuminating on the controller board really led me to the problem.
Don


(greg) #16

Mr. Adams,
Does the limit switches from Andrew work with Carbide Motion, specially the Probing capability


(greg) #17

This Andrew sorry


(Richard Cournoyer) #18

Yes these switches work with Carbide Motion and yes the probe works too. I know what Andrew you meant.

I don’t think you need to ask this question 3 (maybe 4) times. Please


(ryan harrison) #19

Hey man,

Question: Where is the light that comes on when you hit the switch. I’m troubleshooting my machine and don’t see anything come on. Thanks!


(William Adams) #20

The lights are a feature on newer boards — older ones didn’t have them.