Limit switch help


(Jason) #1

Have limit switches installed; changed false to true under settings CM for homing; entered $22=1 in grbl. When try to do homing $h; I get grbl error function disabled. I then try to jog machine then it says to home; so I click home then I get other error that limit switch activated after moving about 1" on x axes. I have the xxl but a standard limit switch kit that I extended the wires and used until xxl limit switches come…any thoughts. Maybe my wire extension is causing problem??


(Roger Newmon) #2

Move the machine off the switches at least 1 inch in each direction then turn it on and try the homing sequence.
Another words when you power it on make sure none of the switches are at their ends.


(Jason) #3

Nope; tried it in a bunch of locations. Question #2;,when you look at your log mine says test with signals receive counter going up…how long should that test be…seems to never end. Also how do see the entire grbl defaults my list is very short


(Jason) #4

Some pics…


(Roger Newmon) #5

try without the / in front of the commands. I don’t think any of the $ commands need a / in front in CMotion.

Use $$ to see all settings. If $22=1 it should allow you to home. If not it may be an issue with the bitmask for the switches or a faulty switch somewhere.

The settings you are looking at are actually software settings, nothing really to do with the GRBL settings.
Not sure about the “Test” message, I’ll check. But the message count will always go up each time it gets information from the controller as to x, y and z locations.


(Craig) #6

Have you verified the settings were written for your machine? If you open the terminal and type $$ and enter, it should give you the machine settings.

Which limit switch setup did you install?

Do you have an ohmmeter to troubleshoot wiring?

Have you modified any other settings?


(Jason) #7

I have the standard limit switch from Carbide for the standard SO3; too short for the xxl so I extended the wires. No mods on any other settings (as I wouldn’t know hoe anyways…lol). I have a volt meter Im sure will have ohms on it; how do I test that; unplug put testers on pins and activate switch???
As with putting / in front of $$ commands; it says to do so in CM but does it really make a difference? Thanks.
I have been using machine anyways but I can see the benefit of homing already if doing same job multiple times…would like it to work.
As for machine settings the only thing I see is X,Y travel limits ($130,$131) are most likely for standard so3; I should probably change these too to match XXL cut size.


(Jason) #8

Oh and another thing; when it tries to home before it cuts out after a couple of inches; X axes is going Left…should it not go Right?


(Alex Kahn) #9

I went through all these issues yesterday lol

So step one
Once switches are in place, turn on:
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
to enable them (for Grbl 0.9 and later).

step two you did by clicking the true false things on shapeoko has homing
you can also set the table size here right under it shapeoko table x,y “420.0000” I set it both to 1000 because … because.

you should now be able to do $H which is sounds like you were able to do with just the $21 so maybe the x direction problem was because you didn’t enabled $22=1 or the table size was too small and it stopped itself?


(Jason) #10

Followed all these directions; still a no go. Get limit switch activation alert…bad switch or bad wire extension job I’m thinking. How to test switch??


(Craig) #11

Ohm between the pins on the Molex. Not sure if you have NO or NC switches, I use NO look for a change in state when you move the axes manually.


(Alex Kahn) #12

Im getting limit switch trigger warnings randomly too. In fact i unplugged them it was happening so much and guess what… still getting them randomly…even with no switches. Going to try a diffrent controll program see if that makes a differences.


(Jason) #13

I think I have a bad z axes switch which explains the sudden limit switch activation as z is too move first I think. I put meter on molex and get a reading of 10.8 for both x and y switches; manual push switch and numbers change. As for z I get 0 or 0.1 and numbers don’t change when push switch. Picture shows setting of volt meter.


(mikep) #14

Yes, your Z switch is broken.


(Jason) #15

thanks for the confirmation…


(Craig) #16

Other possibilities could be the extension is shorted, or the switch could be wired incorrectly, or a combination of issues.

To test the switch itself you could unsolder the wires and ohm thru the switch and also thru your wires. You could do this by only removing one wire from the switch.


(Jason) #17

Ah… Give up…took switches off…will just wait to receive the limit switches that were supposed to come with the machine and try again…thanks for all that helped.


(Argenis ) #18

Hi

I have the same problem with “Z” axis switch.
I install al the switches (without modify cables) when I setting up, the “Z” switch was working good but in my second homing test, the “Z” axe don’t stop when hit the limit switch…

:frowning: I test the switch with a multimeter and they don’t work.

(sorry for my English It’s not my native language.
Please edwardrford


(Rocky W) #19

Is there just a simple way to turn off the limit switches? or the mandate to do homing?

I don’t understand the need for the homing and limit switches. I always end up “babysitting” my machine anyway. Is it just so that the machine doesn’t hit the edges and keep running. If I recall correctly, the limit switches were an add on.

Problem: (2nd time this has happened; after first time Carbide sent me a new limit switch for the Y axis) When I start up my SO3 XXL when plugged into my computer Carbide Motion always makes me Home the machine first. So, I click on Homing to Begin and then after a few seconds I get the warning that the limit switch is hit. However, none of the three of my limit switches are actually being touched. The gantry is more than 6’’ away from each switch.

The switches do depress when I manually push them so I assume it is not that the switches are mechanically broken. I’m assuming that another one has a bad wire like the first time this happened.

My biggest concern is the projects I need to cut tomorrow but Motion will not let me do anything while the “limit switch is hit.”


(Luke) #20

If you are using GRBL 1.1 you need limit switches.

Based on your second problem your switches are not setup correctly if they have been triggered before being hit.