Limit Switch Hit error


(Patricia Beckmann Wells) #1

Hi -

Unable to Home. ‘Limit Switch Hit’ error immediately when choose ‘move cutter’ > ‘click to begin homing’.

Downloaded and reinstalled Carbide software. Rebooted several times.

EC button was indeed engaged. Rotated it clockwise (per arrows on red button) to disengage. Error repeats.

Reengaged EC, rotated it again to disengage. Rebooting machine, and switched USB ports.

Continually set off the ‘Limit Switch Hit’ error.

Unable to manually move the spindle and motorized parts when the unit is powered on. I am able to move the spindle and motorized parts when the unit is powered off.

I wonder if this is similar to issues experienced with 3D printers wherein the limit switch itself is bad? I tried this on a Windows 8 64 bit machine and a Windows 7 64 bit laptop. Same error in same pattern.

Here is code from the workstation:
Test Waiting…
GRBL_RESET
CarbideMotion 0.9g
<Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.>
___________$# ___________
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:513.000,883.000,-108.560]
[G59:-102.410,-111.220,-127.570]
[G28:0.000,0.000,0.000]
[G30:-220.000,-10.000,-5.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]
ok
<Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.>
___________$h ___________
ok
___________$# ___________
ALARM: Hard/soft limit
GRBL_RESET
[Reset to continue]
CarbideMotion 0.9g
[’$H’|’$X’ to unlock]
___________$X ___________
<Alarm,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:3,Ln:0,F:0.>
___________$X ___________
[Caution: Unlocked]
ok
<Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.>
___________$# ___________
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:513.000,883.000,-108.560]
[G59:-102.410,-111.220,-127.570]
[G28:0.000,0.000,0.000]
[G30:-220.000,-10.000,-5.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]
ok
___________$# ___________
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:513.000,883.000,-108.560]
[G59:-102.410,-111.220,-127.570]
[G28:0.000,0.000,0.000]
[G30:-220.000,-10.000,-5.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]
ok
<Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:0,RX:0,Ln:0,F:0.>


(Richard Grier) #2

I had a similar issue. I centered the table, with the power off, and the error went away. I was then able to proceed normally.

Just a user, Dick


#3

What dickgrier said, try manually centering with power off.


(Nicholas J Mathis) #4

I also encountered the “Limit Switch Hit” error. As per DickGrier’s suggestion, I turned the power off, centered the table manually, then powered back on.

I do not encounter the error after doing this.

NOTE: I encounter this error by engaging the limit switch either manually (by moving the table all the way forward of backward while the machine is off and leaving it there) or during the “Move Cutter” operation (by moving the table all the way forward or backward while jogging).


(Patricia Beckmann Wells) #5

Worked! Thanks. What I did not realize is that the center shaft was hitting the switch limit. Manually lowered this and the switch limit ended.


(Rob Grzesek) #6

FYI- the new Carbide Motion we’re testing right now will not let you jog until you hit a limit switch. We’re trying to add a lot more intelligence into Carbide Motion to eliminate these errors (that are too easy to do right now).

-Rob


(Richard Warren) #8

I’m having this same issue after crashing the z-limit. Centering the table manually does not correct it. Any suggestions?

Thanks - RMW


(Gus) #9

Try to move the carriage block down. The hit limit is not specific about x,y, or z. In your case, it seems that’s Z. Centering the table will not leave the hit switch state off. You’ll need to move the thing down a little bit (enough to disengage Z end switch).
Hope this helps.


(Richard Warren) #10

Thanks for the input Gus, I neglected to mention that I did move the Z manually. To clarify: I powered down, moved X/Y/Z to make sure the switches where not depressed, checked each switch to see if any seemed to be damaged of stuck closed. Everything appears to be okay.

As far as I can tell I either damaged a switch (logically the Z) or there is something software related wrong. As a check on the software issue I tested CM with my SO3 and it works fine.

I have an email into support, and will probably call tomorrow if I don’t hear back.

Thanks again.

RMW


(evilphox) #11

Did you ever get an answer to this because i’m having the same exact issue after the what I thought was a Z crash. I only do PCB’s so I thought it was weird since it was about half way done when it happened and I’ve never had problems before. I tried all the usual things. If i double tap the z limit switch it will home but it’ll never measure the tool and wont home after that.


(Apollo Crowe) #12

@evilphox
Try cycling power and re-connecting Carbide Motion.

If your still having a “limit switch error” issue, email support.

It could be a damaged switch or it could be the Gcode.


(Mike) #13

I had the same issue, exact error. I tried repositioning manually, resetting defaults, and reasserting the homing settings too. As a last ditch effort before contacting support, I checked the functionality of the limit switch with an ohmmeter. It turned out that my z-axis limit switch failed, indicating always closed (should be normally open). I think these switches are just cheap. I tried a homing sequence again, this time manually closing the circuit and the machine ran normally.

I bought a replacement switch on amazon (http://a.co/aIavcrf). Although it’s not identical, it’s functionally equivalent to the original (and now I have spares). Reinstalling the new switch required opening up the mounting hole on the switch just a bit but it otherwise fit really well. I added an M2 screw to the adjacent hole to prevent the switch from rotating out of position as this new switch does not have the post that prevents this.

If you’d rather have the exact homing switch that the machine shipped with, you can buy it from digikey here.

After installing the replacement switch, the machine was fully functional again.

Hope this helps.


(mikep) #14

I’ve had the same trouble with the switches -they don’t seem to hold up very well to overtravel. They’re quality, sealed, Omron switches, they shouldn’t be this problematic, but they seem to be. I’ve also found a couple new ones that wouldn’t work (electrically) until clicked a few times by hand, maybe to wipe the contacts a few times.