Lock Spindle RPM in Carbide Create toolpath


(Steve Cramer) #1

I control the spindle with a relay using the PWM output from the Shapeoko control board. I have to manually check that the RPM is above 10,000 RPM or the relay chatters and the router does not run. During most work I have earmuffs on, I control a shop vac on its own relay and it will run making it hard to hear router not running, have to E-Stop the job before crashing bit into stock. I try to always check but have missed a few. Locking retract height would be great as well. I seem to be able to change retract height to zero with out changing any other setup parameter.


(Adam X) #2

Not sure which part was the question there, but you can set the spindle speed in CC here, which should keep your relay logic tripped;
image


(Luke) #3

You can also add a 240v or 110 v led to your router. I too am not sure of the question


(Steve Cramer) #4

What I am looking for is to have the RPM on all toolpaths set to 10,000. You have to untick “Set Speed automatically” and then set RPM above 10,000. The Shapeoko does not natively use the signal, so why not set it static?


(Adam X) #5

This software drives both the Shapeoko and Nomad machines, and the latter certainly does use the speed parameter - as such it’s in there and must be specified.


(Steve Cramer) #6

In Job Setup you have to specify what machine you are using.


(Adam X) #7

You can try setting $30 to a value of say 1000 then. That should cause any speed value over 1000 to push a “full” pwm 5V. YMMV.


(Steve Cramer) #8

It seems that only works for Grbl 1.1. I’m still on 0.9.