Motion Install Issues


(John Ellenberger) #1

I couldn’t get Motion running on Ubuntu so I bought a refurb Win10 machine (cheaper than buying Windooz) and it seems to be working fine except for motion It is running a legit from the factory Win 10 64 bit.

If I install motion it installs with the 64-bit runtime package I get the infamous “missing .dll” error. If I reinstall the 64-bit runtime I get the same thing. Then I added the 32-bit runtime and motion starts up and gives me the connect to cutter panel. If I try to get connect I get the “cannot find” error that I was getting under Ubuntu.

Works fine on my 64 bit Windows 10 laptop. Not on this desktop.

Any suggestions on how to get this to work?

I have UGS working fine but I didn’t realize that Create puts out a proprietary stream and UGS chokes if you try to feed it a Create “gcode file”.


(William Adams) #2

You can get plain text G-code out of Carbide Create using Carbide Motion, but you have to be connected — Catch-22.

Is UGS keeping the comm port busy?


(John Ellenberger) #3

No. I am not running anything else when I try to connect. Meanwhile I can connect via PTTY and UGS.

I didn’t have this problem on my laptop but I wanted to move to a desktop machine because of the dust–my nice laptop was getting filled with sawdust.

Next stop Regedit to completely clean and reinstall.


(John Ellenberger) #4

The one odd thing about this machine is that it came with a parallel port and 2 serial ports. Haven’t seen those in years.


(John Ellenberger) #5

Ok I am out of ideas on this. I uninstalled everything including drivers and VC++ stuff. Hand edited the registry removing anything with “carbide” in the string.

Reinstalled Create first (it installs the 32 bit VC++) and it works. Reinstalled Motion (it installs the 64 bit VC++) and I get the same “GRBL Cutter Not Found” error. However if I get my nose up to screen I realize that it flashes the info panel for a 1/2 sec. before I get the “Connect” screen and then of course if I try to connect I get an error. However when it is trying to connect the steppers make their little jump so it must be touching the port(?)

Because my other machines don’t have physical serial ports the USB COM port is the only thing to find. This machine COM1-COM3 are hardware and COM4 is the USB port. Is it possible that Motion gets confused and grabs the wrong one? Is there any command line switches to force it? – port=COM4


(William Adams) #6

Yes, I doubt Carbide Motion has ever been tested on a machine with physical COM ports. Check in with support and maybe we can get a developer to look into it.


(Greg Smith) #7

I had some install issues with a new tablet a few months ago. Not sure if the issues are the same, but here is the thread that got me pointed to my solution: Carbide Motion Startup Error


(Phil Thien) #8

Trying disabling the other serial ports under Windows Device Manager?


(Scott Conant) #9

I would second Phil’s suggestion. Go to device manager and disable the serial and parallel ports.

Right click on “This PC”, select “Manage”.
Click on Device Manager, select "Ports (COM & LPT)"
Then right click and select Disable for each serial and parallel port (not the Shapeoko port)


(John Ellenberger) #10

Yes I did that and no joy. I also reinstalled after disabling the ports just in case. Also tried various compatibility options.

Haven’t seen this before on a Win 10 machine. It just never finds the cutter. I can talk to the cutter via UGS and a terminal but no Motion. Guess I’ll have to focus on non-Create alternatives since there is no way to get Create output to the cutter.


(Phil Thien) #11

The serial port created during the install has some options I think, like setting the COM port (COM4 I think may be the default). Have you tried to adjust any of those settings (via Device Manager)?


(John Ellenberger) #12

I did try bumping the baud rate up to 115200. Not sure what else I would set. The Events tab looks normal.

Also forced the machine to do the annual update (“creator update”) and deleted all the COM ports rather than just disabling them (except the COM4 usb).

I’m afraid this is down in the bits somewhere. App runs but can’t talk to the device.


(Jim Amos) #13

Have you tried renumbering your COM ports? I’ve not concluded my experiments, but in my monkeying around with dual controller boards that are hubbed, Carbide Motion wanted to talk to my Estlcam board, I believe it grabs the lowest port number. It should discriminate by looking for “Shapeoko3” ID, but I could be all wet (I’ve yet to prove any of this).

This would all be easily mitigated by surfacing the desired port in some type of settings dialog. This, and many other practical settings (like persistent user selected file paths) are code-design 101 items.


(John Ellenberger) #14

So as I mentioned I have deleted all but the COM4 USB port so there is only one currently. Just for grins I a renumbered it 1-2-3 and 5 and no diff. Since the port is clearly working because other software interacts with it just fine. Not sure what Motion is looking for but it doesn’t like my machine.


(Phil Thien) #15

If I was going to proceed further with diagnostics, I would likely wipe/reload with a clean install of Win10. You should be able to download the image (from Microsoft) and get it onto a flash drive. Then, boot from that flash drive, wipe the existing partitions, and load Win10 from scratch.


(John Ellenberger) #16

Well this machine is a just out-of-the-box refurbished HP machine so Windows is about 1 week old and I just did the annual update on top of that so it hardly seems worth reinstalling Windooz–it hasn’t had time to develop .dll fever yet. In fact it is running fairly snappy at this point.

I bit the bullet and bought vcarve and so will be using UGS and vcarve as my main toolset. Create/Motion doesn’t appear to be very mature.