New SO3 XXL stops at same line of code


(Peter Wong) #1

I just sent in a support ticket with this information but I figure I’d hit the forums too. I just purchased an SO3 XXL and I’m machining holes onto a wasteboard for work holding.

9.2 % into the job, the SO3 stops moving, and Carbide motion indicates that it’s on line 6809 of 74355. Ten seconds pass, I abort the job. It looks like Carbide motion was still connected to the SO3 because I did not receive any errors and I was still able to job the XYZ axis around.

Here’s the gcode along with the respective line numbers:
6808 X648.696Y648.725
6809 G1Z-7.036F381.0
6810 G1X648.617Y648.810F1524.0

FWIW, I’m using a 1.5kw spindle. The spindle cable is shielded and grounded.

Any help from someone with more experience in the Shapeokos that I have is greatly appreciated.


(William Adams) #2

Saw this in tech support and am taking the liberty of repeating the response from there.

That’s strange. That line is quite ordinary and ought not generate an error.

​First consideration. Is this repeatable? If you submit the job, say for an “air cut” w/ no material or endmill loaded, does it still error out at the same line? If so, please fill us in on the details of CAD/CAM, providing source if possible and we’ll look into it.

​If it’s not repeatable, it’s most likely EMI (though usually that’s not recoverable / hangs up the connection).

If that’s the case, please try the following things (which you are comfortable with and which you feel apply to your situation):

  • arrange the AC cable for the router so that it doesn’t cross or be near any of the other cables
  • if you’re using a laptop, ensure that it is plugged in, preferably to a grounded outlet using a 3 prong plug if possible
  • if you’re using a USB extension cable or unpowered USB hub, please directly connect the machine directly using a shorter than 6 foot USB cable — if your cable doesn’t have a toroid (metal cylinder often molded into the end of the cable) and you have a cable which has that feature, try it
  • try a different USB port, esp. if you have the option to switch from USB3 to USB2 — if using a laptop try a good-quality powered USB hub — some laptops undervolt the USB ports to save power.
  • if your router power cable doesn’t have a toroid, try adding one (note that what seems to be a toroid on a Dewalt DWP611 is actually an anti-theft device on all the ones I’ve seen)
  • if possible, connect the router and the machine through a different circuit
  • if you have a surge protector, please connect the machine through it

Please ensure that there aren’t any extraneous wires which create ground loops.

Hopefully some combination of one or more of the above will get you cutting reliably — if things still don’t work, let us know and we’ll work with you to resolve this.


(Peter Wong) #3

I had a different job that was repeatable but I disregarded it at the time and no longer have that particular file. This one is not repeatable and works fine in the air so I’m going to chalk it up to EMI. Rather than trying to figure out whats wrong, I’m just going to throw chokes and isolators all around, wherever I can. I ordered a bulk pack of ferrite chokes, usb isolator, and even found a used but in decent condition isolation transformer. This should completely decouple everything power and connection-wise between the spindle and my SO3. I guess despite the fact that my spindle cord is shielded, there’s other potential sources of EMI. I still have a 20 ft SO cord that’s providing the 220V to the VFD. From that same cord, I’m taking one of the branches to provide 110 for my SO3, computer, etc so I’m sure that doesn’t help.