No "Toggle Shapeoko Homing" button visible after updating XL to CM4 and GRBL1.1


(Malcolm Overend) #1

Hi, updated the GRBL to 1.1 using the installer but it doesn’t seem to recognize the homing switches anymore. They all worked fine with v3. I held the z-axis switch while updating. Now my machine is a giant paperweight. I can’t even run it without the jog panel.

Anyone else run into this problem?

Can I downgrade to the old GRBL and CM v3?


(William Adams) #2

To revert to CM3 see:

To get homing working, it should “just work” — verify your settings against: http://docs.carbide3d.com/software-faq/shapeoko-3-default-grbl-settings/ and see if http://docs.carbide3d.com/shapeoko-faq/shapeoko-enable-homing/ helps.


(Jared Hooper) #3

I upgraded like you and was a bit confused at first because the “Toggle Shapeoko Homing” button wasn’t there but it seems that sending config data did enable the homing switches. Did you click the jog button at the top when you’re on the screen you posted the pic of?


(Malcolm Overend) #4

Thanks, guys! I was able to still home the machine on the jog tab. The button still doesn’t show up on the settings page…but everything seems to be working.

The instructions page might need to be updated if this is the new normal. Might keep others from freaking out like me.

Thanks!


(Jared Hooper) #5

Yes, the instructions for that reflash mention nothing about the “Enter Sparkfun Code” button but instead show a picture of that button reading “Toggle Shapeoko Homing”. Definitely confusing.