Nomad 883 Pro, X Axis Reversed Direction Glitch/Crash

(Cameron Ebersole) #1

First time using my Nomad 883 Pro, going through the homing sequence. I have Carbide Motion V4 installed.

The Z and Y axis home fine, but the gantry moves to the left (side without a limit switch) instead of the right, and crashes into the side of the machine. Typing $23=1 fixed the problem, and now my homing sequence runs complete, with the spindle stopping in the middle of the machine after hitting all 3 limit switches. My new problem is that now when preforming the tool-depth automation, the gantry still travels left instead of right, and crashes into the machine then.

Any ideas on what I can try to change, or potential work arounds?


(William Adams) #2

Please check in with

For machine movement/direction this is governed by:

  • the mechanics of how the machine is assembled — I believe that’s invariant for a Nomad
  • how the stepper motors are wired (there are a bunch of ways to reverse a stepper motor)
  • the settings which one makes in Grbl (which you have changed by $23=1)

For homing, there are settings / compile options which will determine those directions/functionality

(Mark Walker) #3

Sounds like Carbide Motion thinks it is a Nomad (Original) instead of a Nomad Pro. Weren’t they flipped per the tool measurement and the limit switch?

(William Adams) #4

Excellent point, which is exactly why I didn’t want to theorize beyond base principles.

(Cameron Ebersole) #5

I think it’s reading as a PRO correctly, below is a screenshot of my settings when I connect the machine.


What are your direction mask settings? ($3 in the GRBL configuration)

If you don’t know how to get this, you need a terminal program (like putty). I think the com settings are 115200bPS, 8-N-1. Type $$ to get the settings. As you are GRBL 1.1, you need the cheat-sheet for what the descriptions are. Prior GRBL had it in the response, but memory limitations required the removal of the text in 1.1