Sparkfun code for CM


(Lewis S Poteet) #1

I just updated my Shapeoko XL to grbl v1.1 and installed CM v4. I followed instructions to open CM, click connect to cutter, and then clicking settings. and then using the dropdown to seleck my machine, which is an XL, and then clicking send config. Nothing happens. There is a box saying to enter sparkfun code. I don’t know what that is, but seems I am out of business without the code.

Does anyone know what the code is. I did not purchase from sparkfun, but from carbide3d directly.

Thanks,
Lewis


(William Adams) #2

You shouldn’t need a Sparkfun code with a Carbide Motion board.

Please contact beta@carbide3d.com regarding difficulties with the beta. If you wish to revert to Grbl 0.9 and CM3:


(Lewis S Poteet) #3

CM is asking for a sparkfun code, so it looks like my machine was shipped with a sparkfun board.

I bought the machine from Carbide 3D, order #5803.

I’ll contact beta@carbide3d.com to see what the solution is.


(Scott Conant) #4

No, Carbide Motion is asking you to select your machine type. Mine for example was the Shapeoko 3 XXL,so I chose that in the drop down then clicked on the “Send Config Data” Button. If you don’t have a sparkfun, just ignore that button.


(Lewis S Poteet) #5

I did that, selected XL, and clicked the send config button. Nothing happened. Instructions then say to click the toggle Shapeoko homing button, but there is no such button showing.

I’ll try using CM tomorrow and see if it works, but I doubt it will. I also tried closing CM and then clicking settings again, and it is still asking me to send the configurations.


(Scott Conant) #6

homing button is on the jogging screen


(William Adams) #7

Please post a step-by-step including screen grabs. I hope it’s some simple misunderstanding.


(Michael Mora) #8

Did you ever figure this out? I assume that carbide motion now knows that homing switches are installed and you don’t have to enable anymore?