Suckit Dust Boot and X axis limit switch


(Joshua Rogers) #1

Anybody got the suckit dust boot and x axis limit switch? How did you mount yours? Also, I’m assuming reducing the overall x dimension in grbl will be necessary?


Upgraded to carbide 4 grbl 1.1 cannot manually set axis size?
(Joshua Rogers) #2

Nevermind, I swapped it to the opposite side of its mounting plate and ground the corner off the plate itself so it wouldn’t hit the belt clip before the limit switch plunger was depressed.
\


(Jim N) #3

@Stumpy Incase you missed it, below is a link to the Suckit SO3 install video. The limit switch assembly starts at 3:43.


(Joshua Rogers) #4

That pushed the mounting screw head too close to the drag chain and they interfered. More of an issue with my drag chain than the suckit design.


(Ryan) #5

This is a bit off topic, but how long did it take you to receive yours? I ordered back in January and still haven’t gotten mine.


(Jim N) #6

@rnelwan Best thing to do is send them an email asking for an estimated delivery date. They (Jenn and Mark) are very responsive. I bet you get an answer within an hour!

I was an early kickstarter so I got mine end of December and it’s been fantastic!


(Sean Riley) #7

I ordered mine when I ordered my S3XXL In late Jan. I got an email last week that my suck it will ship next Friday 3-17.


(Dan Nelson) #8

Just got mine yesterday and started install today. Order January 11th, so it took about 2 months. Shipping to the US was one day as they shipped DHL. One thing about DHL is they required signature for delivery, however if you get on their website you can sign and request that it be left at your door without you being present.

Install went pretty good, my limit switch fits tight, but works fine. The one thing I’m having trouble with is crashing into the left hand rail side and can’t remember is how to limit X for in quick jog mode. I searched on here and couldn’t find my answer, or tried what I found and it didn’t work. Think I have to reset the bed size, but couldn’t make it work. I’m on an XXL running CM4 and Grbl 1.1. Anyone have the fix handy?

Thanks,

Dan


(William Adams) #9

To reduce the bed size for the purposes of rapid positioning and soft limits, please see the homing switch installation and configuration instructions: http://docs.carbide3d.com/article/67-shapeoko-3-limit-switch-installation


(Dan Nelson) #10

I think I need to explain this better:

In CM4 you only get the choice of SO3, SO3XL, or SO3XXL for configuration. In my case X of 830 crashes the gantry because my dust boot is slightly wider than the Z plate:

So I went to the MDI window and set X at 800 using $130=800

I then verified this in the log using $$:

And X is indeed set to 800:

Then I try to rapid position using CM4 and Crash!!!
Then I look at the actual position in CM4 and it shows 815 (I hit my Estop button so as not to kill my belt, don’t know if it would have gone further):

I am still a newbie, but this suggests to me that even though the machine knows it has limits, CM4 does not know when to stop and/or it still thinks the bed is wider than it is? Or maybe I lost the plot and just need a nap?

Thanks,

Dan


Touch probe no longer going to be offered?
Upgraded to carbide 4 grbl 1.1 cannot manually set axis size?
Rapid Positioning on Shapeoko 3 seems confused and thinks its an XXL?
(Neil Ferreri) #11

@DanoInTx Do you have soft limits enabled? $20=1


(Dan Nelson) #12

Yes, tried that and I get the following error:

It really seems as though CM4 has the positions hard coded for Rapid Positioning unless I’m just missing something obvious?

Thanks,

Dan


(William Adams) #13

I believe you’re correct, and that Carbide Motion needs to either read from the soft limits set in Grbl, or make that number in the preferences configurable. @robgrz


(Dan Nelson) #14

Bummer, that means you can’t Center up your rapid moves either. So I can either shelf my Suckit boot until CM4 catches up, or roll back to CM3. I have another really good dust boot, but I was hoping the Suckit with fixed height might solve my Z belt slipping during deep plunge issues(my other boot moves with the Dewalt and I think the bristles foul Z sometimes). I’ll probably roll back to CM3 for now. Is there a simple roll back procedure for Grbl 0.9? Thanks as always,

Dan


(Joshua Rogers) #15

I assume someone has requested configurable rapid position coordinates? Or at least a center based on “shapeoko table parameter/2” ?


(Dan Nelson) #16

In CM3 the settings tab allowed one to set the various settings line by line, but CM4 just gives you SO3, XL, XXL. It’s great for a straight standard setup as you can’t really get anything wrong, but from what I gather many of us don’t have bone stock machines so it’s pretty limiting unless we use a different GCode sender. I’ll probably roll back to CM3 for now.

Dan


(Jim Amos) #17

I finally adjusted my X extents today for CM3 rapid positioning with my relatively new SuckIt boot (now @ 820mm). Interesting to learn this has been deprecated in CM4?


(Ryan) #18

Sent them an email and they were in fact quick to response. Thanks for the suggestion!

@thesignguy Glad to hear it. I finally got an email from them over the weekend. :slight_smile:


(Dan Nelson) #19

I don’t know if it has been depreciated, and it’s a beta release so for all I know there’s gonna be some big change by the time of actual release? I’m not trying to make any money using my machine, so I can hope that this along with some other reported issues (10 key jogging broken, showing wrong/no filename on load screen still as of beta 4.07) will get corrected before it’s a final release. I really like the speed overrides, smooth jogging and other features in CM4 so I hate to roll back to CM3 just to make it work with my setup. Guess we’ll wait and see:)

Dan


(Jim Amos) #20

Losing the 10-key support is something that needs restoration for Carbide Motion… I use my BT keypad for CM/GRBL and Estlcam all the time. The Estlcam jogging has always been smooth as silk, and CM/GRBL herky-jerky, but can deal with it. It would be nice to see that mitigated.

I’m waiting for more CM/GRBL 1.1 refinements before jumping over.