UGS Suicide Button


(John Ellenberger) #1

I have been using UGS for a few months now and one thing really troubles me. I still am tempted to push the “return to zero” button on occasion, but every time I do really really bad things happen. Normally my Shapeoko 3 (Sparkfun ed.) slams against one or two limits and then dives into the wasteboard damaging the bit.

Near as I can tell this never works even though it would be fairly useful if it did. To me it should move gracefully to the last time I RESET ZERO but it never does. Am I missing a step like saving some parameter?

In general I don’t see any helpful documentation on UGS. Has anybody found something the would explain some of these things like how to save offsets, what reset zero actually means, etc. ?


(Adam X) #2

It’s this somewhat opaque nature that turned me away from ugs, to be honest. I’ve been using grbl-panel and have been extremely happy with it, once you get the hang of how it likes to do things.

I suspect the crash you’re seeing has something to do with a misunderstanding or miscalculation of the coordinates vs the current work offset and the machine position. Specifically G54-G59 work coordinates, G28/G30 pre-defined positions and G92.

When I started moving beyond Carbide Motion (which is great for what it is, don’t get me wrong), I found that doing a dump of my grbl settings and then reading them through next to the grbl configuration explanation page really helped put 2 and 2 together for me about how and why my machine was doing what it was doing.

grbl pre 1.1: https://github.com/grbl/grbl/wiki/Configuring-Grbl-v0.9
grbl 1.1+: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration


(John Ellenberger) #3

Ok thanks. Been to that page many times. GRBL is pretty well documented (unlike UGS).

Guess I’ll put on my debugging hat and try to figure out what UGS is doing based on the input codes. Just seems strange because it never actually heads to project 0, home zero or anything rational. It just goes crazy and ends with the bit crashed into the table.

I may retry chili pepper. First time I found it cluttered and confusing. Maybe if I stare at it long enough.


(Will Winder) #4

I’m guessing you’re using v1.0.9? If so try upgrading to the latest stable 2.0 build. The return to zero button used to monitor Z heights and would get confused when work coordinates were reset. It currently simply sends G90 G0 X0 Y0 (and raises Z if it is currently <0).


(John Ellenberger) #5

Thanks I actually went all the way and did V2 and the New GUI. Really like the improvements! And it did a return to zero the right way!

I had been sticking with the classic because I was under the impression that the new GUI required me to upgrade GRBL and Sparkfun sez they won’t support that. The latest build / new GUI seems to work with my 0.9 controller.

Only thing I didn’t like was the Z having a continuous jog setting. I am so used to just 1/0.1 that I find zeroing kind of painful in Z. Having just two settings was easier on my little S3.

That said am not looking back. UGS 2 for me.


(Matt Freivald) #6

In UGS you should be able to jog exact increments along any axis using keyboard jogging. This is especially handy if you have one of those super cheap hand-sized wireless numeric keypads. You change the jogging distance to higher or lower with the +/- buttons, jog in X and Y by tapping the arrows, and jog in Z by tapping Page Up / Page Down. The box “enable keyboard jogging” (I think) has to be checked in the UGS main screen for it to work.

Beware of holding down keys, since keystroke repeat will make the machine jog repeatedly.


(John Ellenberger) #7

Yes that’s the “feature” I was complaining about. For Z I was happy with just two choices in the classic. Now I have to redo my whole zeroing routine. Technology marches on but I sometimes wish GUI designers could curb their enthusiasm for “helping” me…especially the ones that work at MS.


(Will Winder) #8

I’m glad the new version is working for you, thanks for the update.

What exactly is it about the jogging UX that you don’t like? The continuous mode isn’t a UGS feature, that’s the operating system repeating key presses if you hold it down – and it hasn’t changed. The jog window hasn’t changed much either, and both versions of the 2.0 GUI use the same design.


(John Ellenberger) #9

I think we’re talking about two different things. The classic GUI only had a “1” and a “.1” setting for jogging. Using that my procedure became to jog in 1" to the Origin; Switch to mm and get close using 1mm ; Switch to .1mm for the final Z adjust.

The new GUI has a pull down on Z with a continuous scale of increments (I’ve only seen 1 to .1 but I assume pretty much anything goes). Getting from 1 to .1 with the mouse is 10 clicks. Since I prefer mousing to keyboards/keyboard shortcuts it just lengthens the process.

I guess I am getting a bit overly anal about this (and the tool changes) because I have to crank out a bunch of pieces for my daughter’s company which means lots of repetitive setups.


(Will Winder) #10

Ah thanks you’re right I missed what you were saying completely. I probably considered that a bug when I noticed it, really interesting to hear that it was a feature for you. Thanks for the feedback.

There is an option to divide the step size by 10, it’s buried in a menu (Machine -> Jog -> Step Size -> Divide by 10), you can create a keybinding for that to make it easier to access. Then maybe switch your routine from 1 inch -> 1 mm -> .1mm to 1 inch -> .1 inch -> .01 inch?