Unable to Open DXF File Created in WingHelper


(Steve Labuta) #1

Hi All! New to the forum and thinking about purchasing a Shapeoko XL for cutting RC Airplane Parts… I’ve been using a little Program called WingHelper to create airplane wings. It has an option to export it’s information as a DXF file for use in other programs, like Carbide Create. The issue I have is that Carbide Create will not open the files created by this program. I am getting an error as shown.

Error

The error could be in the DXF file, but other programs (Fusion360…) can read it. I can work with the creator of WingHelper if there is an issue in the format of the file. Can someone help me understand the error so I can continue on my investigations for a small CNC machine! If I open the file in Draftsite and resave it, then Carbide Create will open it but with the wrong scaling. There is something in this file that Carbide Create does not like.

Thanks!

Steve Labuta

UFO-2.dxf (285.3 KB)


(William Adams) #2

Unfortunately, Carbide Create is still pretty limited in which DXF constructs it can import.

From: https://www.shapeoko.com/wiki/index.php/Carbide_Create#Import_DXF

it may help to use the OVERKILL command to eliminate any overlapping or intersecting paths before exporting from AUTOCAD
if lines have different elevations, use FLATTEN [10]
PLINES are intrinsically joined, and should be used where appropriate [11]
AutoCAD 2000 DXF format (model geometry only, base model scaling) export from the desired face (not isometric view)
2004 Lines

Other options include opening and re-saving the files — I usually end up opening in LibreCAD, saving as MakerCAM SVG, then fixing in either Inkscape or some other tool.

Please send any problem files in to support@carbide3d.com and we’ll hopefully get them added to the test suite and importing properly.


(Jose Prieto) #3

What you need is an interface program, try opening in ilustrator save in .svg or as Will says.


(Steve Labuta) #4

Thanks Will and Jose. There are some overlapping lines in different layers, that is probably the issue. I’ll keep playing and experimenting…

Steve