2.2kw spindle not turning on with "spindle in command"

(Stephen Taylor) #1

Alrighty… Finally after three faulty vfds I got one that will turn this spindle! Everything works, except once I hook the board up there is no response at all from the vfd. As soon as I unplug the PWM and ACM is turns on and I can change speed with the dial.

I did do it per lukes post
Connect the PWM pin to VI
Ground Pin to ACM

Is there a setting I’m missing?

0 Likes

(Luke) #2

Have you changed the PD settings to enable external speed controls?

1 Like

(Stephen Taylor) #3

That would be pd1 to = 1 right? If so then yes.

Edit:
Pd1 - 1
Pd2- 0
Pd4 -400
Pd5 - 400
Pd070 -1
Pd072 - 400

Is what I’ve changed.

0 Likes

(Luke) #4

I don’t have a manual infront of me at this point, but I note your wires change colour between the VFD and the control board?

0 Likes

(prune) #5

Got the same issue… change the DIP switch on the right to be on the VI setting (left).

3 Likes

(Stephen Taylor) #6

Haha… I knew someone would notice. I ran short so they are spliced together. Waiting on a little more to arrive in the mail. I’ve made sure they do end up going to the right place.

1 Like

(Stephen Taylor) #7

I haven’t even noticed a switch. Is there one in the newer boards? Im not home to look right now.

If so that’s exciting.

Edit. Just noticed that’s the vfd and not the shapeoko board. I’ll do it when I get home

0 Likes

(prune) #8

Was really disturbed because it was not working at all when I first plugged it in this morning. Until I noticed this. Manual is saying it should be on VI by default, which is not the case at least for both of us !
Once changed everything is working fine ! Happy carving (at least for you, one of my water cooling plug is broken and I’m waiting for a spare to arrive… one day… in june maybe… :frowning:

You can thank Me Beaver who told me about your issue :slight_smile:
And you can thank him (as I do here) for all the support and the nice HDZ + mount stuff !

1 Like

(prune) #9

BTW, I think PD2 should be set to 1 (it’s the case for me).

Also, I set PD141 to 110, which is the voltage here in Canada, but also the one written on the motor (default is 220v). Strangely, all the documents comming with the motor say it should still be set to 220… I think I don’t have the guts to try it out… :slight_smile:

1 Like

(Stephen Taylor) #10

Yea this one is a 110v. I’ll probably set that one to it.

0 Likes

(Stephen Taylor) #11

Actually I believe that is for the motor yea. So mine is already set at 220 so I’m leaving it haha

0 Likes

(Stephen Taylor) #12

This was the issue. Moved and and it fired right up to 10k rpm.

Finally it works! So excited.

3 Likes

(Stephen Taylor) #13

It still works. Question about the probe. I have everything grounded. And attaching the magnet to the spindle makes it throw an alarm. How do I get this probe to work with the new setup?

0 Likes

(mikep) #14

You need to be a little more clear on “everything grounded” The probe itself should not be grounded to anything. The ground wire with the clip (some replace this with a magnet) goes to the end mill - going to the spindle itself can be a little problematic if it’s anodized, etc.

If you touch the ground wire to the probe, does the light go out or turn green?

0 Likes

(Stephen Taylor) #15

I’m using a non carbide 3d probe.

But the probe is wired to the circuit board on the machine per normal (by the x,y,z pins) and with the old DeWalt I’d put the plate down and attach the magnet to the collet and probe.

With the spindle I have everything grounded to one plate and the probe is wired the same as it always has been. When I attach the magnet to the spindle collet and use my probe macro it won’t even move and just sets an alarm on cncjs. If I take the magnet off it will probe but will jam into the plate if I let it.

0 Likes

(mikep) #16

Don’t attach to the collet, attach to the end mill. The coating on the collet nut can interfere.

3 Likes

(Stephen Taylor) #17

Alrighty I’ll try that when I get home and let ya know.

0 Likes

(bartosz) #18

You need to make sure that you’re attaching probe’s ground wire to the spindle not the signal wire. It didn’t make any difference when you were using palm router because there was no continuity between the bit and a router’s body. Your spindle is grounded (or at least SHOULD be) so if you attach signal wire it will throw out a ‘probe fail’ alarm. Don’t know what your setup looks like but I’m having similar problem on my diy cnc after installing aluminum waste board. Will have to physically isolate aluminum plate from the machine’s frame.

Quick question, does anyone have a problem with the vfd displaying rpms that are highly inaccurate? When using cncjs and trying to run spindle at 12k rpm through the software, display shows 14,5k rpm. Actually anything between 12-20k rpm is usually off by around 2k rpm. Is that just a display error or is there any other reason this would be happening?

3 Likes

(Stephen Taylor) #19

So I didn’t get to the probe part but I noticed I was setting my speed at 10k and the vfd was reading like 4-5k not sure what’s up with that

0 Likes

(Luke) #20

Ah I bet your PWM input voltage is set to take 10v rather than the 5v the shapeoko board pushes out

3 Likes