Adding tools in CC440 and later

This is a bit different — the tools are now stored in CSV files

Windows: Help | About | Open Data Directory
Mac OS: Carbide Create | About | Open Data Directory

to access the carbidecreate/tools directory), and it is first necessary to add a New Library:

after clicking on the “New library” button you will get the “Create new library” dialog:


make appropriate selections (note that certain endmills only appear in certain materials — at this time, MDF has the most complete listing — further note that one aspect of this is the suitability of an endmill for a given material — a #251 should not be used for metal work, so does not appear in those libraries) and click “OK”. Note when naming that the machine type and material will be added as a suffix — a consideration to avoid department of redundancy department naming:

EDIT: note however that it is still required as of this writing that one use a period as a decimal separator both in the OS and in CC.

To actually add a tool to the new empty library, right-click on it and choose “New Tool” from the contextual menu:

then make appropriate selections in the sub menus:

Note that only certain characteristics are currently accessible (it is a beta) — it may be necessary to go into the CSV using a text editor or a spreadsheet and fill them in — it will also be necessary to work up suitable numbers for feeds and speeds.

1 Like

Worked up a default library with median speeds (50 ipm) which one can use to experiment with the machine moving at up to 100 ipm using feed rate override:

50IPM Shapeoko (758 Bytes)

1 Like

Following your path above, I don’t seem to come upon the tools directory. I see- Fonts, Posts, and Settings. Build 433 12-11-20

On build 449 to get to the tools database goto Edit, Show Tool Database.
The other post would go to the database directory

1 Like

433 is less than 440, so is earlier, not later.

As @Lowbrowroyalty noted, in Build 449, things work as described.

My apologies. Running a few computers, reading initial post on one, trying it on another. Thank you for the continued support.

Best Regards!

Just trying 449 Mac for the first time. Trying to rebuild my endmill library. For me, I was confused why duplicating the MDF library just created a new library with a custom name that was locked. I can’t do anything with it at this point. Any suggestions on how to delete this?

Creating another library gave me the unlocked icon and ability to copy an endmill profile from the CC locked library and paste it into my new one. In trying to edit the profile I noticed that there isn’t a field for the flute length or number of flutes. I can see these in the “Cutter Information” window but not sure how to edit it.

Thanks for your help!

Help | About | Open Data Directory

Go into the carbidecreate/tools folder and delete the underlying .csv for any libraries which you are having difficulties.

@MCISTL There was a post recently (by @WillAdams I think) that explained the flutes and length are not required because CC doesn’t calculate feeds and speed any more.

EDIT: So, I found the post that I mentioned.

1 Like

Wow, this is frustrating. Switched over the the latest build this morning and spent the better part of an hour trying to get to anything that approached what was explained in the OP by Will Adams. Still, all I can get is something similar to what was posted by Mike Myers–had to create new library, then “duplicate library” to get something that will allow copying and pasting of existing tools or creating new tools. Original “New Library” is locked but "user-copy-Shapeoko-MDF is not. Not sure what I’m doing wrong or if there is something missing in the OP directions. I’ve worked back through it numerous times.

Additionally, I assume that the “manual edit” of F&S in the tool setup menu has been done away with. Is the only option to change F&S now in the edit tool dialog setup?

If you can cause such difficulties consistently and repeatably, please let us know at and we’ll do our best to work through them with you.

Yes, feeds and speeds are now done in the library tool setup.

This is helpful. Thank you. To confirm, when updating, all previous bits entered are lost? I have mainly outside sourced bits and was hoping to quickly plugin the info I had from my last CC version into the new spreadsheet.

I believe the .ini file is left in place — if you install an older copy in a different location you can switch between the twain if desired.

Probably the easiest thing to do though is:

  • make a user library in the new version
  • open it in a spreadsheet or text editor
  • install the old version
  • examine all the old custom tooling and transfer it into the user library
  • the edited user library should then load when you reinstall the new version
1 Like

it would be totally awesome if CC would save enough data into the C2D file, so that if you open the C2D on another machine, you could add a tool from that to your library

1 Like

I was able to get it to work, just not by following your directions. Maybe it is me and I’m not following close enough, but when I do this and change the dialog boxes to, say, Material-MDF–Machine-Shapeoko–Library Name-Everett’s Tools and click OK:
I get this: Everett’s Tools-Sapeoko-MDF with a lock symbol next to it. None of the tool groups are accessible and appear empty and it won’t let me copy tools into it from one of the existing files.

However, if I then click on the Everett’s Tools-Shpeoko-MDF folder and click “duplicate Library” I get another file listed WITHOUT the lock that is named: Everett’s Tools-Copy-Shapeoko-MDF and that file can be copied into and tools can be created.

1 Like

Maybe it is just me but I cannot understand why this is not addressed in a future version where you would be asked if you want to import a library from a previous version instead of everyone having to do this convoluted procedure every time you upgrade. Better yet, CC should look through the directories to identify previous library and say: we found these libraries, do you want to import them (with a tick box for choosing each and one for choosing all).


If you close and restart the program any tool library you created will be unlocked and allow you to add tools.


It took a while to find the right combination of events but we managed to duplicate this bug and fix it. Look for 451 to be released today or tomorrow.


This topic was automatically closed after 29 hours. New replies are no longer allowed.