Another laser issue

(Giovanny CERENIL) #1

Ok so I bought a 15w chineese laser finally got it connected correctly. Finally got time to mess with it only to discover that once I started the job the laser stayed constantly on, meaning when it went across an area that was suppose to be blank I got a unwanted line. I’ve tried running on CNCJS, Lightburn and lGRBLlaser. Any help would be much appreciated

0 Likes

(Neil Ferreri) #2

How are you generating the gcode?

0 Likes

(mikep) #3

I suspect either 1) you aren’t generating code with correct on/off or 2) you’re not hooked up to the right input to match up with the pwm output on the board, or 3) the settings on the grbl board for the pwm aren’t quite right.

0 Likes

(Giovanny CERENIL) #4

Through light burn just make my quick design and hit save gcode.

0 Likes

(Neil Ferreri) #5

Do you have laser mode enabled in your grbl settings?

1 Like

(Francisco) #6

Upgrade your controller firmware and be sure to enable laser mode in your GCode sender.

1 Like

(Nathaniel Klumb) #7

Summing up, the three things that seem most likely to cause what you’ve described are:

  1. Wiring up PWM correctly.
  2. Setting and using appropriate GRBL settings:
    • Max spindle speed: $30 = ___
    • Min spindle speed: $31 = 0 (usually)
    • Laser mode: $32 = 1 (GRBL 1.1 required)
  3. Generating appropriate G-code.

If you weren’t wired to PWM correctly, you would most likely have the laser always on (if you were connected to a 5V pin) or always off (if you were connected to ground). That doesn’t sound like what you’re describing.

Not having laser mode set would be more likely to cause burning at the ends of lines (due to things like pausing for the spindle to spin up). Max spindle speed can be anything you’d like, but it sets the scale factor used when you generate G-code. Since you’re getting laser output, while I can’t say your settings are themselves correct, it does not seem as if they would be the main issue you’re relating (although it would be possible, perhaps).

To me, it seems that the most likely issue is that your G-code is bad. Can you just make a small project (just, say, a couple squares) and, assuming it is also working incorrectly, posting the resulting G-code here? If it is your G-code, that’s often easy to spot at a glance.

1 Like

(Dan Nelson) #8

Myers Wood Shop has a YouTube video on setting up Lightburn with a JTech laser, same stuff should be applicable here for the most part:

Dan

0 Likes

(Giovanny CERENIL) #9

Well I will try just a few squares tomorrow afternoon but double checked my setting 30=1000, 31=0, 32=1. I am on grbl 1.1
I tried messing with the height and speeds still no luck. As for the wiring I have a black wire connected to my ground on the shapeoko board and red to the pwm on the board. On my laser I have the black wire connected to - pwm and red wire to + pwm sorry wiring is horrible just want to make sure it’s all correct before I clean it off

0 Likes

(Giovanny CERENIL) #10

Well after trying another simple design I have concluded I had a bad gcode the simple design worked perfectly. Thank you guys for all the help

1 Like

(Francisco) #11

Send some pictures of your work and the laser… 15 watt is a beast!

0 Likes