Another newb, Hello World slight issues

Hey all, thanks for taking time to read this and hope to give me some comments. I have the XXL and just put it together, very carefully with emotion (frustration, happiness, joy, sadness) as the instructions could be quite a bit better, but i got it done. I squared the machine as per instructions, attempted the Hello World and had a few things happen maybe you can help me out to clear it up.

  • After homing the machine and bringing to front of project, lowering pen to just barely above the paper, zero out, run program…the pen jumped up about 1/4 inch and began doing the program above the paper.

  • Cancel, rehome, repeat…pushed sharpie into paper a little hard and tip smashed but the program seemed to run correctly but really thick edges.

  • New sharpie, repeat homing and zero sharpie just touching the paper but not smashing and it ran the program but the middle of the Shapeoko did not get drawn in.

So my 2 issues may be related here, waste board and rails all are level (within tolerance) as i have the feet higher on one side to make up difference in floor slope.
1st, why did machine rise up after initial zero and draw in the air above the paper?
2nd, could my waste board be the problem or the piece of cardboard i had under instead of flat hard surface? I figured the cardboard cushion would be good for the sharpie but maybe not.

I am trying to get all this down prior to putting sharp things in the router. Below is my video of the Hello World.

Thanks in advance!

1 Like

Three things to try:

  • add a spoilboard so as to bring the surface up an inch or so
  • check your Z-axis belt tension
  • remove one of the Z-axis springs temporarily
1 Like

Thanks William.

added extra piece of plywood
belt tension seems ok to me
removed right side spring

I crushed the head of the marker when zeroing it in…ugh, but still seemed to have same result of the machine raising up and ghost writing. I then lowered sharpie until i was touching the paper good and had the below result. Note that when it got to the right side it was significantly closer to the paper as the lines are thicker.

I took my calipers and found the right side of X rail is a little less than 2mm higher than the left side rail however the level shows it within tolerance. Not sure if 2mm will make much of a difference in regards to leveling. Work surface also showed level (within tolerance).

Shall i attempt to loosen the rails and re-square?

Yes, you definitely want it more level than that. Some customers have found it necessary to clear powder coat out of the holes in the motor mount plates — over the span of an XL or XXL it doesn’t take too much to get things uneven.

So far i have found a few of the eccentric nuts to be off and tightened them down a bit, that seemed to make it a bit more solid.
I did notice that after zeroing out everything i could add a +0.50 to the Z axis and it would get the pen closer to the paper but would still ghost write. Not really sure why it gets zeroed out with ink on the paper that it ends up ghost writing. I believe i need to check more things on the Z axis, maybe readjust the belt.

This thing is so close to alignment and it all seems to be working correctly other than the Z axis.

check the z-axis set screws? it’s always the darn set screws. Double check one of them is fully contacting the flat.

I have similar but opposite problem with my shapeoko 3…No matter what software I use, ugs carbide motion etc
I cannot control the dept of cut… Supposing I set a profile cut of 1/8 inch for example, I get 4 passes of 1/8 giving 1/2 inch cut…?? I’ve checked and doubled checked the belt, the pulleys etc. no luck… What am I doing wrong? Hope someone can guide me through this…I’ve been using foam as material… No damage done so far luckily.

First, check your software defaults: — if nothing is off there, please post a compleat description of your job setup / workflow, and include a simple file which exhibits this problem on your machine using your workflow — it may be either a simple misunderstanding, or some bad part.

Thanks for replying. So how and where do I find the gbrl settings on my machine?

It’s pretty much as that link describes, but instead of the control key, send $$ to the machine, and the settings will then be displayed in the Log window.

So I’ve done the comparison. Might have found the problem??

Line missing $14

Line different

$ 102 = 320.000 (z, step/mm)

Line $130 = 290.000 (x, maximum travel)
Line $131 = 290.000 (y, maximum travel)
Line $132 = 80.000 (z, maximum travel)

I forgot to mention that this is the Shapeoko 3 deluxe modell with the sparkfun board.
But I’m thinking that line $102 might be the culprit??

As a follow up. If that line is the problem, how do I proceed to change it ??

Send $102=40, or whatever value you wish — it should be the same as $100 and $101 since same belt and pulleys on all axes.

Let me guess, you tried installing / using Easel?

Yes I did use easel, is that not recommended?

So how do I change this setting?

Thanks a bunch

Easel overwrites the Grbl defaults with what it expects are okay for an X-Carve.

To change them back use:

Thank you very much for that info. I will try that tomorrow… Last time I tried to connect to Carbide Motion thou I was getting GRBL error and I couldn’t connect so that’s probably why!! How else could I change this setting now if still can"t connect?

Thanks buddy

Yeah, it’s a Catch-22 you have to be able to connect to set the defaults — you might need to uninstall the Easel driver / other software. We do have a tech note on trouble-shooting connection to the machine: — if none of that works, put in an e-mail to and someone who understands this better than I will help you puzzle it out.

Thank you very much. You were a big help…I bought this cnc way last summer but got busy and sidetracked at other things during the fall and then the Christmas season an I kinda got away from it. Now I’m anxious to get it going properly… Thanks again

This post reminds me of my ex, always talking about her problems never mine.

How did your check of the set screws go?