Assembled and ready to go, but initializing won’t complete because of homing errors caused by limit switches not working

Help! I just bought the Shapeoko XXL and we finally got everything assembled, including the t-track, bit zero, and bit setter add-ons. I bought a new Microsoft Surface because I thought I was going to use VCarve with it, but the Illustrator + Carbide Create + Carbide Motion flow will work for me. I brought the Surface into my shop and was excited to set it up and do a test engraving before working on a real project. But nope! Carbide motion keeps failing the initialization because it says “homing failed…” something about it not being able to find the limit switch (aka proximity switches?). We tried turning it off and then back on. And then placing something metal (like the wrench that came with it) on each of the limit switches to see if the lights lit up, but no… none of them lit up. We then checked all of the wires and connections and everything checked out… it’s all connected. We’re at a loss! Why won’t the limit switches connect? We can’t we get the machine running. It was SO much work to assemble this, we really don’t want to have to return it. I wrote Support, but are hoping someone here has an idea of what’s happening and why we can’t use the machine. Did we get a dud?! Please help!

Thanks,
Jacquelyn

Always recheck your wiring to the motors, limits etc. being new likely something simple

1 Like

We double checked everything and it all looks right to us. We’re at a loss. The Z proximity (limit) switch was preinstalled. We installed the X and Y, but none of them are lighting up.

When you say none of them are lighting up? They only light up when a piece of metal is right in front of them. You should be able to push the Z lower to gain access and test each one of the switches (XYZ) by placing a piece of metal (I use a wrench). Of course the machine needs to be turned on and connected.

PS: the homing switch plug is not as tight as I would like to see, and can easily unplug. Please check that first.

1 Like

Did you configure Carbide Motion’s settings to setup that you’re using an XXL?I had a similar problem when I set mine up - I want to say it was after midnight and I was anxious to do the hello world sample. Well… that didn’t work out. It was due to me not having selected the Shapeoko 3 XXL under settings, which will configure you’re max X/Y values.

1 Like

Hey, all. So apparently you need to send the correct configurations to the CNC before anything works during the initialization. I did that and got it initialized. I also set up the Bit Setter, but that wasn’t exactly intuitive, but it’s done. Now, I just need to learn how the heck to set up my toolpaths and such so the gcode aligns with the wood on the CNC and cuts accurately.

1 Like

The problem is that when you google the error message that CM returns the search results return articles about issues with the homing switches. Trust me been there done that! What should pop up ‘is this the first time you’re setting up CM and to actually set it up’.

Couldn’t CM do a check on this or at least give this as a possible solution to the homing failure?

100% They need a series of step by step video tutorials for first time users across the hardware and software.

This might help.

1 Like

I have a draft procedure for homing issues on new or upgraded proximity switches. Please check it out and give me any feed back you may have.

homing_problems.pdf (1.2 MB)