bCNC problems with Shapeoko 5 Pro

I got my 4x4 Shapeoko 5 pro up and running last night. It worked great with Carbide motion on my windows laptop. However, I plan on using bCNC on my raspberry pi in my shop. I use it on my other CNC (workbee with open builds black box) and I previously used it on my X-carve as well (with X-Controller) with no issues.

When I went to use bCNC with my shapeoko 5 pro, I was able to connect successfully. I ran the home command and it successfully homed. However, after that the shapeoko would not respond to any input, it wouldn’t even jog. I restarted and even ran a simple unlock command ($x) which went through fine but again nothing worked after.

I have a lot of experience with GRBL (all the way back to the original shapeoko in 2012), however I understand that carbide uses a slightly modified version. Could that be the cause of these problems? I am going to troubleshoot some more tonight, but I wanted to reach out here to see if someone has an easy fix. Some things I plan on trying:

  1. Disabling bitsetter in carbide motion
  2. Disabling soft limits.
  3. Using another Gcode sender

I am really hoping to get bCNC working. I use my machines for repetitive production work and I don’t want to click through a lot of dialog boxes for every operation in carbide motion.

We can’t help with bCNC, but the first step would be ensuring the machine is working w/ Carbide Motion — please write in to if you have any difficulties with that.

I realize Carbide is not going to help with bCNC. I’m hoping someone else here has encountered the same thing.

It works fine in carbide motion. I also got it working in UGCS. I even downloaded bCNC on my windows laptop and that works. It appears to be a problem with my raspberry pi 3 running bCNC (it works fine for GRBL v1.g).

It looks like the buffer gets hung up when it sends the status after homing. I think it is expecting a different response and ends up stuck waiting for it.

Has this happened to anyone else?

You should try reflashing the firmware for the USB chip. I looked up your order, and it might have been shipped just before we got it fixed. Give it a shot at Shapeoko 5 Pro Firmware Update

1 Like

Thanks Rob, I’ll try that tonight

Reflashing the chip solved the problem. Everything is working great now. Thanks Rob!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.