Big problem - Nomad is making loud grinding noise (Z axis)

Was in the middle of machining a hardwood block, when all of a sudden the machine started going nuts making a loud grinding noise. It flashed that a limit switch had been hit before I hit the shut off button (but I wasn’t near any sort of limit)

When I turned it back on, and it asks me to home the machine, this is what it does

I can move the carriage manually freely along the Z axis - there is no binding at all. Only when I turn on the machine and try to move the cutter does the sound start happening.

Rob - any ideas??


I’ve seen that happen when there’s a loose wire in the motor connector.
I sent you a PM so we can trouble shoot it.

Just got off a call with Jorge (thanks Jorge!) and we got to the root of the problem - a wire leading to the Z stepper motor had broken.

Jorge is sending me a new wire harness - excited to get rolling again!

The Nomad is making a very loud grinding noise when traveling on the negative z axis. In Carbide Motion I go through homing then it tries to do a tool measurement. When it moves in the -Z direction (down) to the tool measurement indicator the stepper motor makes a grinding noise and stalls by fully depressing the tool length indicator. The machine can also stall out right before it moves down to the tool length indicator. This is only the second time I used the Nomad - first was the renshape head. I posted videos at the attached links. Is this the same problem that Darren had?

It sounds like it could be.

First thing you can do is feel the wiring harness at the back of the z motor to see if one of the wires is damaged. I actually did this and it seemed fine, so Jorge walked me through how to take the top of the machine off (it is really easy) and it turned out one of the wires was damaged. Jorge sent me a new wiring harness and the problem was solved.

Hi, got the same problem. Any help?

I received and installed the new cable. Problem solved! Thank you so much Jorge.

i had the same thing. Jorge to the rescue for me too.

Hi, my Nomad / learning cnc experience has not been without hiccups, and now I’m encountering the issue of this thread - violent noise and sputtering motion when ‘measure tool’ sequence starts. It seems to point to the wire harness fix. Jorge to the rescue, please? Thanks

@pjhof, shoot me an email to and we’ll get it taken care of.