Bit Setter and deep initial plunge - Newbie

Hi everyone,

Let me state clearly I am a NEWBIE. :slight_smile:

After spending 3 days (partial days) of assembling my Shapeoko 4, lots of fun.
I went through all the initial tutorials for learning about the machine. I did the Hello World project with the marker. During this project I Disabled the Bit Setter (FYI I don’t have the cooler BitZero.). This worked fine after I zeroed z a little lower so it wrote on the paper.

Next up I decided to try a little project - cutting a placemat (oval) out of 1/16 inch Plexiglass. I added a stock starfish to the project and used the V Bit, Ballnose, and Mill End bits to engrave the starfish and Final Cut the Oval out of the stock. I converted everything to mm’s so I could be more accurate. 1/16th inch = 1.5875mm The Starfish uses depths from 0.30 mm to 0.50mm.

After Initializing the machine and re-Enabling Bit Setter, setting Zero’s (x,y,z), I even used the cool paper trick to ensure that the Z axis was just touching the plexiglass. I was excited to give it a try. During the Initialization I installed the 302 V 60 degree Mill End when asked for bit change, it did us the Bit Setter during the initialization which gave me some confidence. I then hit Run and it called for another bit change, which I simply resumed, it then did the Bit Setter again (Cool!!!).

Excitedly watching as it moved to the initial Node. I watched as it slowly moved down and made contact with the plexiglass, and then the horror as I watched it plunge through the Plexiglass, into and through the waste board, and finally into the Aluminum T-Track. :frowning: Unfortunately I was at the front of the machine watching in excitement and it took me a moment to move around to the side and hit Pause, Stop, and the Red Stop which finally stopped everything (the Pause and Stop seem to be very delayed, another question for later). The 302 V broke off the tip and some of the aluminum fused to the edge of the Mill(bit). Luckily I am in the 30 day window and Carbide is great!!!

But now I am terrified to use the Bit Setter because I can’t seem to explain what I did wrong.
Any assistance is appreciated. FYI I have been told by Support that Carbide doesn’t have setting for the 302 V and hard plastic, but given I was trying a 0.3 mm cut of 1 inch in length they indicated that it was probably ok. Given that the plunge cut through the plexiglass was very clean (no chipping or cracking I thing I would have been safe if it had stopped at the 0.3/0.5 mm level.

I have uploaded the C2D and NC files, incase I missed something.
Plexiglass placemat with Starfish design.c2d (653.0 KB)
Plexiglass placemat with Starfish (339.4 KB)

Is there anything I can do before hitting run to ensure that all the setting are right for the initial?
Aka what are the initial setting (depths), before doing it what would be the initial node movement, etc??? Any other diagnostic stuff I can do to gain confidence in the Bit Setter and the User???

Thank you,
The DougMan

I looked at your .c2d file in Carbide Create and the .nc file in ncviewer and nothing there jumps out at me as a problem. When you built your machine did you do the step where you send/push the machine configuration via Carbide Motion (ie. specify the machine, z-axis type, etc…)?

I’m also assuming that you set your z zero at the top of your plexiglass as you did in carbide create and not the bed/hybrid table level.

(edit: you can also check by jogging a certain distance on the z-axis within Carbide Motion and confirm that if you move 50mm up or down that this is the actual distance traveled on the machine itself. If you do not have the correct z-axis selected in your config then this can be off)

1 Like

Hi Patrick,

I did go through the installation instructions step by step including sending the configuration.
Is there a local file I can check to see that the right values are in the file and resend it?

Yes, I zeroed Z and X&Y to the top of the plexiglass bottom left corner (NW). Even if I had set it to the bed I would assume it would have gone 0.5mm into the waste board, not entirely through it. :frowning:

I will try the jogging, but I will mention that the Hello World project did not have problems and the only difference is the Bit Setter.

Thank you,

If you have problems when introducing the BitSetter it’s caused either by changing the tool w/o using the interface to change a tool, or the Z-axis configuration being wrong.

Ok. I will try Bit Setter again on a small cut.
I did save each tool path combination off as individual GCodes and ran them without Bit Setter and had no problems (other than the 302 V cut looks like —. You get the point or more so I wish I had a point. :frowning:
While I hovered over the STOP during each pass they all did what was expected and it looks ok.
Lesson learned about holding the material, I used hold downs on the outside the material but because it is so thin (1/16th inch) there was uplift in some places which caused the bit to be deeper in some places and shallower in other. Will try Double sided tap the next time I am doing thin materials.

Still haven’t figured out what went wrong with the Bit Setter pass but that will a have to wait until next week. Happy Fourth of July and than you for all the help.

The DougMan

I’ve experienced some strange behavior before when enabling or disabling the BitSetter after setting my Z Zero. Make sure after you either enable/disable the BitSetter that you follow this up with setting your Z Zero height again on the machine.


Hey Doug,

You seem to be comparing the BitSetter and the BitZero here. It’s worth noting they are not related to each other and do not do the same thing as each other.

Your BitSetter will not set your Z zero, or arbitrarily measure the length of your tool.

It will only change your existing Z zero by the difference between the the tool it probes, and the last tool it probed.

1 Like

Quick follow up and thank you to everyone for taking the time during the 4th of July weekend to help a newbie. After taking a quick beach vacation with the family I returned and re-enabled Bit Setter, cleared all Offsets, set Zero All again at 3/4 inch just in case. Ho, and resent the Config file to the machine to be sure. I did a dry run and watch very carefully (testing depth of mill end with 3/4 scrap board). With three mill end changes and a complete run everything worked great.

Shout out for Carbide 3D’s - 30 Days - Mistakes are on Us warranty, replacement parts on are their way. Assume!!! That is an incredible feature, only wish I could have it start a specific day since it took me 3-4 days to build the machine (very slowly and carefully) and then vacation :frowning:, but hey it is still assume!!!

Thank you everyone.
The DougMan

This topic was automatically closed after 30 days. New replies are no longer allowed.