Bit setter failure

I have the shapeoko 4 xxl and I just received the bit setter for it. I’ve connected it to the front of the machine and connected the wire to the labeled plug in the control box.

  • I start Carbide Motion and connect it
  • I initialized it and it ran it sequence fine
  • I jogged the bit in the x,y so it’s directly above the button, then lower the z to about 1/4" above the button
  • I go into settings and check the box to enable the bitsetter
  • I push the “use current location” button
  • I initialize the machine again
  • I’m asked to change bits (i have the 1/4 " round probe that came with the bitzero installed)
  • It does it’s initilizing then moves above the bitsetter button and the z axis moves down only about an inch then i get a failure to probe box pop up. the z never goes down enough to even come close to the button.
    I’ve restarted everything twice and still does it, software is current build
    not sure what to do???

Someone had a similar problem with the Z Plus lately. Their problem was with a short bit not reaching the BitSetter button.

Can you jog the machine down to push the BitSetter button? If you can jog down to the button then not sure what is wrong. If you cannot jog down far enough to push the button then check your configuration and increase the Z paramater and send the configuration. Just be careful you do not set a value that exceeds the physical limit of the Z-plus mechanical limit.

1 Like

yeah, I can jog down to the button with more to spare.

Hi @WVDesigns,

Can you check the BitSetter is not already triggered when starting the initialization ?
Power up the machine, connect but don’t initialize, go to the Settings pages, and check what the “GRBL Active Input Pins” line shows ? By any chance does it say “PROBE” ? If it does, that would be a sign that either the bitsetter or a probe is triggered/active, while it shouldn’t be at this stage.
When this has happened in the past this was often

  • either a problem in the BitSetter connection or BitSetter itself
  • or a touchprobe inadvertently left to touch the machine’s frame, grounding the probe input.
    What happens then is that the controller will start moving down to the BitSetter, begin its probing descent, and then it will report an error because it sees the BitSetter as already active before even moving all the way down.

Do you have any error pop-up messages in CM ?

1 Like

I figured it out.
The probe button was frozen solid, I needed to apply a lot of pressure between my thumb and finger to get it to compress. Then it moved like it was covered in grit, I pressed it up and down until it was moving freely and springing back up on its own with a snap. re ran the starting sequence and it worked as it should. I’ll try doing some cutting with it later today or during the week to see if it’s accurate.


I have a similar, but yet different issue i have been working with customer service on but to no avail as of yet. I have a Shapeoko 3xxl, z-plus axis with a 2.4e board. The router will move to the bitsetter and drive down, even after fully depressing the bitsetter button it continues to drive causing everything to vibrate. The red light for the bitsetter is on but it does not seem to be recognized by the carbide motion software. I have replaced the proximity switch in the bitsetter and most recently completely replaced the board but have the same exact issue. I have even deleted and reinstalled carbide motion…another symptom seems to be that the grbl does not show a change when i press the bitsetter button… it remains “ no active pins”

Does anyone have any idea… it seems to be a software driver issue but there is no additional driver to download to my knowledge.

The software driver just determines if Carbide Motion can communicate with the board — the communication is all text and numbers over the serial port, so not really subject to driver issues.

If you haven’t already, let us know about this at and we’ll escalate and sort out what the issue is with you.

first diagnostic is to go to the settings screen in CM and then manually press the button.

there is a “live view” of all the limit switches there (also try one of those to know where to look).
It really should show the button triggering on and off. If not, then well that is what needs to get fixed (wiring or whatever)

1 Like

Only slightly related, but if someone searches to find this down the road… my BitSetter fails if my BitZero is triggered. The other day I had my zero with the magnetic prob resting on top and bitsetter wouldn’t work.

1 Like

That’s not a failure insomuch as a design limitation — they are the same input, so can’t be differentiated.

I tried that. It remain saying “no active pins” this occurs when it is plugged into “reserved” and alternate “p” locations on control board. Only change is when it is plugged into the “f” pin on the control board. …. The grbl log also shows inactivity

Sorry, i got this post confused with another post on a similar subject

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.