Bit Setter problem- machine crashes when initializing

I just got my bit setter plugged in and set up. I followed the directions from - here

During the setup I noticed that my default XY limits were set to 800+mm which I assume is one of the larger sizes, even though I had the standard size selected in the settings. I went ahead and changed them to the 350-400mm range that my machine has. I double checked all the GRBL settings and from what I know, they’re correct.


SO heres the problem - When I initialize the machine, it goes through the homing cycle and then rapids to center X and crashes against the front (Y negative) plates. I assume it’s trying to make a tool change, but the settings are wrong, so it never gets to the Y position before it crashes.

My guess is that my problem lies in the same issue that caused the standard XY limits to be that of the larger machines. I have tried reseting the GRBL to ensure I had the standard size selected, but it only changed them back to the incorrect settings. I looked up the tool change location and see it is hard-coded, so I’m now looking for the answer as to why my machine thinks it’s twice as big as it is.

thanks for the help

1 Like

Did you “Send Configuration”?
Carbide Motion does its own thing that can be independent of your grbl settings.

Yes. When I hit that, it resets any changes i’ve made and goes back to the XY being set to 850/845 mm

Did you follow the procedure here?

1 Like

I had to update carbide motion, But I followed that page, and still no luck. out of curiosity, i tried to change it to a different machine default. When I hit send configuration, it only resets back to these settings regardless of what I select or manually input. -

Sorry, I don’t use Motion, but I’m sure @WillAdams would be able to help out.

Well thanks for trying. I haven’t gotten into any other control software yet, this is all relatively new to me.

1 Like

If you haven’t already contact us at

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.