Bitsetter Not Working Correctly (I THINK)

So I got my Bitsetter this morning and couldn’t wait to get it installed. Followed the directions exactly as written (much better written than my Shapeoko directions - nice job Carbide 3d). Everything seemed to be perfect, followed the configuration directions and setup the device in Carbide Motion newest version and centered bit over the Bitsetter. And that seemed to be right too. Powered down the machine and Carbide Motion, restarted both and went through the machine setup for initial start. The machine homed (back right), moved the spindle to the middle front for the bit to be inserted and then when I thought it would move over the bitsetter (on the front right) to measure it went back to the home position in the back right and tripped the limit switches. Any ideas what is wrong?

Did you use your MACHINE position to set up the BitSetter location? The numbers should be negative.

I followed the instructions exactly. After the setup homing I zeroed the location, zeroed the offsets and the pulloff distances were like .19 inches.

I moved the bit over the bitsetter in the front right and it was like -32 and -1 or so if i remember right. It is like those locations didnt get written to the control board.

I do have a modified Z with a screw but I wouldnt think that earlier code change would case these settings to be any different.

I did turn off the setup for the bitsetter and put the machine back to the normal XXL settings and then configured it again. Same result, back right tripping the limit switches.

Are you using inches?
Did you click the “Use current XY” button?
I don’t think you need to power cycle anything. Maybe you did that too early. The BitSetter info is stored locally, in Carbide Motion… Not on the controller.

I came back from lunch and tried it again. Now when it tries to home I get an Error 13 from the controller telling me to close the door. I dont have a door on a Shapeoko XXL. My guess is something fried my control board. Now it wont home at all

Power down, unplug USB, try again.

Just tried that. Now when I open CM it asks to connect to cutter. As soon as I do that is throws a screen that says Door Open. Can get by that. Same on other senders. Some will only connect and when you try to home nothing happens. Doesnt even throw a error code.

I seem to recall some “door open” errors related to the early days of the xyz probe. Something to do with using an alternative connection point on the board?
Something to think about until one of the experts comes up with your answer. Meanwhile I’d open a ticket with C3D.

Door open errors are usually caused by a problem in how homing switches are plugged in.

Please review all the connections and if you don’t find anything obvious to correct send in photos of all the connections to support@carbide3d.com and we’ll do our best to help puzzle things out.

Well the Bitsetter problem is mute at this point. During the process of installing it, something happened to the control board and it is fried. Worked with Carbide3D support and we have another one coming. Support did an awesome job helping me get this resolved however, the Bitsetter issue is on hold till I get the machine back up and running.

More to come on this next week after the board gets in and installed.

3 Likes

Got the new board in and it still goes to the back right corner after I execute the step following the bit change. I set the X/Y coordinate via the software button. It acts like it has all the axis reversed in the GRBL settings. Perhaps that is the case since I am using a different setting than stock for some settings.

See GRBL settings below and let me know if you see anything that would cause this.

$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 2 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 255 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.010 (Arc tolerance, millimeters)
$13 = 1 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 1 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 100.000 (Homing locate feed rate, mm/min)
$25 = 3000.000 (Homing search seek rate, mm/min)
$26 = 25 (Homing switch debounce delay, milliseconds)
$27 = 5.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 39.849 (X-axis travel resolution, step/mm)
$101 = 39.874 (Y-axis travel resolution, step/mm)
$102 = 200.000 (Z-axis travel resolution, step/mm)
$110 = 5000.000 (X-axis maximum rate, mm/min)
$111 = 5000.000 (Y-axis maximum rate, mm/min)
$112 = 5000.000 (Z-axis maximum rate, mm/min)
$120 = 400.000 (X-axis acceleration, mm/sec^2)
$121 = 400.000 (Y-axis acceleration, mm/sec^2)
$122 = 750.000 (Z-axis acceleration, mm/sec^2)
$130 = 845.000 (X-axis maximum travel, millimeters)
$131 = 850.000 (Y-axis maximum travel, millimeters)
$132 = 80.000 (Z-axis maximum travel, millimeters)

Are you homing to back right?

Yes it homes to the back right, comes to the front center to get bit change, then goes back to the back right and trips the limit switches

are you using negatives on the bit setter location?

I used the following direction from the installation directions.

With your spindle directly above the BitSetter, click the Use Current X/Y button to set the location.
This will permanently save the X/Y location of your BitSetter.

It show X at -1.XXX and Y at - 31.XXX. Dont remember the exact locations that were in the blocks

Interestingly enough, setting up CNCJS with the macros Neil developed worked like a charm. Unsure why Carbide Motion is seeming to reverse the locations.

Hi @Bonch,
That’s really weird. Motion uses the same rapid command to get to the BitSetter. It’s just a G0, standard gcode.
Can you get a screenshot of Settings–>Setup Shapeoko? My guess is this numbers are positive, but clicking “use current XY” should correct that. Like I said, weird.

1 Like

Another wierd thing motion is doing is the axis controlled is not what is pushed. If I click on the X+ the Y and Z axis are moving and other weird combinations. All my other control software works correctly. I think i have the latest version of Motion but going to check when I get home and download again. I dont plan on using Motion but this anomaly is kinda interesting. I may make a phone video of both Motion and CNCJS and post them so people can see.

1 Like

Well I am done with Carbide Motion. I cannot get it to do anything right. Try to move the Z axis the Y moves. Then no matter what I try to move the Y moves. Reset and move the X they Y moves.

No other sender does this. Thinking back that is why I quit using it a few years ago. Not sure what is the issue but it has to be something in the software conflicting since all the other senders I have work fine.

The BitSitter works great with CNCJS thanks to Neil.