Bitsetter question - pushing hard into the button thing :)

I apologize if this has been addressed. This has happened before and I was able to correct it using advice from another post, but I just can’t find it. :frowning:

Bitsetter was working great! I turned it off bc I was doing basic contours with a 1/4 bit so I didn’t need bit changes. Turned it on today. Re-checked the box for bitsetter. I initialize, it goes to the front and then over to the bitsetter. Here it is continually pushing HARD onto the button. I had to do a red stop bc it was shaking the machine.

I know it’s probably a quick fix. Would one of you kind people remind me?


Which machine do you have? SO3, SO4, Pro, SO5 Pro, or HDM?

Where/how is the BitSetter mounted? Post a photo?

Where/how is the BitSetter wired up and plugged-in? Post a photo?

When you power up, what colour does the BitSetter show? If you press the button what colour does it light?

Do you have a BitZero? Where is it? Where is the groundlead for it?

Answer all of @WillAdams questions. However a quick check would simply be to push the BitSetter button down and see if the red light comes on. If the red light does not come on look at your connections to make sure something has not been pulled loose or the cable has not been damaged.

If the red light does not come on when the button is depressed the router will keep going down and finally time out. So figure out why your red light does not come on.

The BitSetter and BitZero are interconnected. If the magnet/clip on the BitZero is grounded then it will cause issues. So make sure your magnet/clip is not touching ground.

Attached are the pictures. I have a 4XXL.

Yes, it is wired up and plugged in.

Bitsetter doesn’t light up at all.

BUT - could this be it? Two days ago, while initializing (and me using it all morning WITH the bitsetter), it suddenly lost power. It was not the power source. Tom and a friend took a closer look…he builds circuits and he came over to test it. We tested it with a meter and there was power all the way to the connector into the control panel, but as far as power from the control panel to the switch, it seemed as if there was a break at the connector between the switch and the line to the control box.

We talked to support, did more digging and found that the black wire from the switch came loose from the connector. You guys are sending a replacement part. In the meantime, Tom was able to “jam” it in so that I would have power. I’ve done work without the bitsetter since he did the temporary fix. When enabling bitsetter, it initializes, comes forward and prompts a tool change (I hadn’t loaded a file yet). It had the #201, so I was just leaving that on. When I “okayed” the tool change, that’s when it came to the bitsetter and tried to drill through it. Again, the machine was shaking and the whole thing. I tried shutting the whole thing down…but it happens the same way.

Could it be bc of that wiring problem we had?

The Micro-fit connectors require specialty tools to disassemble and remake. Getting the replacement part should address this.

Gotcha. Yeah, he just rigged it so I can get some work done. I’ll have to put off the orders that require multiple tool changes.

If under warranty support will help you. If you are out of warranty I recall from other posts there might a fuse inside the BitSetter. Only take it apart if it is out of warranty to avoid warranty problems. FYI.

We will help folks even if out of warranty.

The fuse is in the BitRunner v2.

I did not mean to imply that C3D would not help but if you have the ability to investigate the fuse then that might get you back up and running now. When you have power outages there are often power spikes when the power comes back on.

Thanks for reaching out. Here, as Will has said above, it probably has to do with the bad connector we have for the power switch. Waiting on a new one now. This is the third “non-user” issue (bad connectors, etc.) where they had to send us another part. I guess it is what it is.

I’ve been having the same thing happen intermittently on my SO5 where the Z will crash down on the bitsetter while it’s probing (chunk chunk chunk) and I have to jam the E stop and then change my pants and smoke a cigarette.

Based on my scouring of these forums and initial comms with support (who asked me the identical questions), I’m strongly suspecting that my bitzero ground may have been touching the bitzero on those probe cycles where the bitsetter seemingly randomly hari kari-s my endmill (and a piece of my soul). Apparently the machines recognize one “probe” at a time. I’m really hoping that is the answer to both my issue and yours.

Well, they’re sending me a new switch bc ours disconnected. They say that should resolve the issue. We’ll see.

And yes…when that happened, it definitely chipped away at my soul. LOL!