Bitsetter - Red light always on (new machine Pro XL)

Just joined and excited to be part of the community…

I am hoping to have some help regarding the bit setter. I have just finished the build-out of a new ShapeOko Pro XL and I’m having trouble with the Bitsetter. The machine has been wired and configured correctly and all motion is working correctly. However, the BitSetter is not working.

After initialization the machine will come forward and request a tool change, upon resume the bit is centered over the button. The Z-axis will begin to travel downward (fairly rapidly) and then stop after an inch of travel or so (tool still 3-4 inches away from the button). Carbide then reports a probe failure error.

I have noticed that the Bitsetter light is always on. This doesn’t appear right to me. Any guidance would be tremendous. I have checked the wiring, and reconfigured the machine a couple of times, and also running the latest version of Carbide Motion.


Welcome Adrian!

In this situation, it’s a good idea to contact in parallel to let them know that a machine got into the wild with a potential issue; and they can assist if components need to be sent out.

Do you have a BitZero? If I’m not mistaken (SO3 owner here), if the BitZero is not placed in a “good” spot it can ground and send a false positive to the BitSetter.

Given that the red light is always on in your BitSetter… are you able to depress the BitSetter button, does the button move freely?

Sounds like a wiring problem
Open Carbide Motion
Click on Connect to Cutter
Click on Settings
Look on the bottom of the screen where it says no active pins
Press the bit setter button and the “No Active Pins” should change to “Probe”.
If it doesn’t the wiring is incorrect on the bit setter.
I had the same issue with mine and i had to switch the two wires connected to the bit setter.
Either switch the wires or just file off the small tab on the bit setter connector and just flip the connecter over

I believe its the Black and Blue wires you need to switch.
But its much easier to just take a small file and file off the little tab that only allows you to plug in the connector one way. Then just flip the connector over and plug it back in. Carbide can send you a new cable but that’s a pain to try and snake it through the channel to the X axis

This is what mine looked like before i fixed it. Or maybe after i fixed it :frowning: But whatever it is now just switch the black and blue wires


I had the same issue. Contact support, they’ll send the replacement parts immediately.

Loren - thank you for your reply. I reversed the wires and unfortunately the sensor remains on. I did flip the bit zero to the bit setter on the board to test that the bit setter input on the board is working - and thankfully the blue light will come on. So it appears that the issue is probably a faulty sensor switch.

Brian - yep the button is free moving and can be depressed. I do have bit zero but same issue with the bit zero unplugged from the board. Looks like I have may have a bad cable or sensor… but thank you so much for your thoughts and reply - cheers

After taking the bit setter apart, we found that the sensor is always triggered with the button in the up position. We removed the sensor from the body and the sensor will turn off. This indicates that the gain on the sensor is too high or the sensor is too close to the bottom of the button

So to fix this, we sanded the bottom of the sensor to get it a little lower (see below). Then reassembled - the bit setter is now working :slight_smile:



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.