Bitsetter sweet spot for single flutes? CNCjs

Have run into a new issue for me today…on 5 occasions now, when changing tools to a 1/4” single flute, the process fails after the initial touch. At the second touch the led just blinks erratically and the process stops. I’ve been able to work around the issue by rotating the spindle a quarter turn until I get a complete cycle.

Anybody else seen this?

I’ll mess around some more with different endmills once I finish my current project.

Does rotating the spindle have an effect or is it simply the additional trial?

I was under the impression the bitsetter is switched/triggered within the housing (as opposed to conductive) so there would be limited impact of spindle/bit beyond being a physical object depressing button.

1 Like

I don’t know but from the LED, it looks like there is no constant contact. Maybe the switch is defective. Just for the fun of it, try pressing the button deeper to see if it gets the system going again. It may not provide you the right depth of cut but it would point to the problem.

Most likely the additional trial. But I do observe a slight cant to the side when the button is engaged off center.

Tried that right away but still get CNCjs alarm.

@neilferreri CNCjs macro does a triple touch at successively slower speeds, my Bitsetter is alarming at the second touch.

I’ve been using mine since last September, I wonder if the switch is failing?

Did you look at the log to see what CNCjs is receiving from the controller?

2 Likes

i’d check the log as luc mentioned

thinking aloud;

maybe the bounce off needs a bit more travel to allow for the switch/trigger to ‘release’ consistently.
a matter of updating the macro to add another mm or so to the back off distance.

1 Like

Hey @Griff, our version just had a nut at the end of the “button”, if I remember correctly. Check that it hasn’t worked loose.

2 Likes

It’s probably that the single flute has only a point for contact, causing uneven pressure on the button/switch resulting in the bouncing. Reason why keyboards have a “scissor mechanism”, helps ensure even travel no matter where your finger is pressing on the keys.

Possibly…but I do a lot of v-carving, I’ve used the Bitsetter with pointy vbits quite a lot, no problems ‘til today. I’ll check the internals tomorrow.

@Griff I just watched your clip. It looks like the bushing around the button moved. I’d definitely take a look inside.

7 Likes

Neil is right, your bushing is loose. I had the issue and gave it a few turns and no problems anymore.

Also, if you have the touch probe, be sure it’s not grounded to anything. That’ll stop the bitsetter process.

3 Likes

Yep, I saw it move too. I need to check mine and make sure it’s snug.

I just finished up a job where I only used single flutes and made multiple parts and they worked just fine.

2 Likes