Broken Limit Switch

I’ve lost two Z axis switches in about 8 months. No issues with the axis’. At some point I’m going buy 3 or 4 and keep a few spares on hand.


Does the carbide limit switches have a probing capability, I have a S3 purchased prior to them coming with the switches, I like to know wich are better carbides our Andrews? any Idea’s?

Probing and Limit Switches are TWO different things. There is a set of pins on you GRBL board called Probe . Connect a wire to each pin that, BAM, you have a probe. It’s really that easy.

This is an old ver board, but they are all very similar (regarding the Probe pins)

1 Like

I know this is an old topic, but these are the worst limit switches ever. It seems if I don’t use my machine for a month or two they break right off when I fire it up – yes they have literally broken during a homing process. I’ve gone through several, all on the Z Axis, over the two years I’ve had the machine and I treat them very gently. Add to that they are $6+ a pop, plus shipping.

[by “break right off” I mean “right when I start a job”, not as in “off” the machine]

A limit switch is pretty basic, and usually repeatable thousands of times. When you say break right off do you mean electronic failure?

1 Like

Please see

If that doesn’t help, contact and we’ll try to work out what’s causing this — it’s not a common problem/occurrence.

Yes, I agree, it’s a switch and should not be that complicated or fragile. Electronic failure, as in the switch is stuck on. It seems to happen after the machine is not used for a few weeks. I had supposed it had gotten gummed up with small particles and during previous failures and I had tried fiddling with the switch for a few minutes (which according to the s.o. was actually hours) to see if I could un-stick it to no avail.

Yesterday, the events leading to my frustration, I was able to home the machine, start a job, stop it (to change feed rate). Then when I restarted to home it again, poop.

I checked my order history (thank you amazon) and this is the third z-limit switch this has happened to. I was willing to accept one as my fault, one as a bad part, but at three, I’m suspicious.

I checked the troubleshooting guide and believe I’ve got (well not at the moment) the switch installed correctly.

I’m now playing the waiting game for the replacement from mouser to arrive. I ordered five. Hoping perhaps their quality is somehow different from the ones I got on Amazon.

1 Like

You could move to electronic - non touch switches like I did?

1 Like

Reed switches or hall-effect switches? Link?

1 Like

Excellent, thank you!

As the machine is in repair-state, I have more time for “research” and something like this might be just the ticket.

well i have had the same problem with shapeoko limit switches. they are very fragile. not happy, I’ll have to try to find some maybe on Amazon where i won’t have to a long time to get it. Any body have a good Amazon link for a switch?

@stephenhouser @CNCME

These might help you both:

Non contact prox switches, they won’t break ever.

Thanks for the tip on the switches!

Carbide is pretty good about getting these out quick.

1 Like

But the $50 kit doesn’t appear to fit my XXL. Each switch is separate and suspect the wires aren’t long enough. I can’t find my replacement for my machine on Carbide site.
I have pictures. Thanks

We have the homing switch kits at:

Just let us know when you place your order which sort of machine you want it for.

If you ordered and got the wrong one, let us know at

If you have broken switches, either bundled w/ a machine or from the kit, let us know at and we’ll do our best to help.

The Beaver Pro switches come with 3m cables on each switch :smiley:

Having similar issues. Just installed my homing kit last week and the z axis switch was broken right out of the box. Robotshop and Will at C3D did a great job of supporting me and sent me a new z limit switch. I installed it, it worked like a charm for 5 test homings and then started to read that it is constantly engaged (failed like previous one). I have tested the switch off the machine and it reads as being constantly closed (like previous one). I am 99.9 percent sure that it is installed correctly – only tip of switch touching fully raised gantry. Any ideas? Just bad luck with two faulty switches? Would really like to use this thing?
Thanks in advance,

Please let us know at and send in a photo of how you have it installed.

Some folks have mentioned using a switch (temporarily) from an appliance such as a washing machine (could be one could buy them at Radio Shack, but that’s not the store I remember from when I was a kid — back then, had to wait for the proprietor to put down his soldering iron and come up front from the back workroom).