C3D VFD Spindle turns on at max RPM

Hello,
I’m having some issues with the VFD spindle, as it starts running at max RPM the moment my “Power On” button is on and red. GRBL m3 and m5 commands appear to have no effect.
The only two options to stop the spindles are either disarm it from the enable button or press the stop button on the VFD controller.
I’ve already tried re setting the configuration and went as far as reflashing the firmware via the firmware updater, but no lack so far. I’ve contacted C3D and they have told me to essentially reinstall the software, reconfigure the machine. I have already had the PCB board swapped out as well. Did that before doing the reconfiguration. Has anyone else had this issue? If so what was recommended?
Any clue on what might be going on?

Could you have configured for a BitRunner rather than VFD?

No sir, I configured with VFD. They told me now I may have a faulty controller board. Hopefully this may be the fix. I will update when I get the replacement controller board.

Is this a new spindle on a new Shapeoko? or converting from a router?

Brand new VFD spindle on a brand new Shapeoko 5 Pro.

I just had the same thing happen on my new 5 pro with VFD. What was the fix?

They sent me another control box. I just got to work in West Texas, so it’ll be 2 weeks before I can get it swapped out and see if that fixes it. I’m praying it’s the issue. I seem to believe it is very probable that the control box is the issue now due to the fact that there is an issue between the VFD and the computer. Prayer is all I can do for now, but I’ll post up the results of swapping the control box.

Did you ever get to test out the new control? I’m having this same issue

When I got my new 5 pro with VFD the spindle would start and run all the time unless i pushed the button on the VFD controller to turn it off. The problem was in my control box for the 5 pro not the VFD controller. They had sent me a new 5 pro control box and problem solved. If you power up your 5 pro and the VFD the LED numbers should blink with 0.0 and spindle should not run. Before I changed out the controller for the 5 pro I would power up the 5 pro and VFD and the LED would flash 395.5 and the spindle would run. The 5 pro controller was sending the signal to run all the time so if this is what your seeing replace the black control box for the 5 pro.

That is exactly what I am seeing. As soon as I turn on the VFD the numbers are 395 and then the spindle turns on to max rpm unless I turn it off on the VFD

Call the tech support and explain to them whats going on and make sure they send you a 5 pro controller and not the VFD controller.

Thank you, I will definitely be in contact with them today. I emailed them Saturday night after I found out. I was having that issue but planned on calling them today. I will certainly let them know about the controller

Just confirmed today! The new control box solved the issue. When I turned on the VFD it turned on with “0.0” and accepted the MDI commands.

1 Like

I actually just got off a video call with support and they are sending me a new control box right away to resolve the issue. Thank you for the feedback