Calibrate the 'classic' Nomad 883

Hi all Nomads around the globe-

Hope you are all well and enjoying your time at home/quarantine in the shed with your Nomad/Shapeoko mills.

As I’m now able to produce really nice cuts in Aluminium (see previous post) I would like to revisit a question I posed back in Feb 2017 to see if any of you contemporary Nomads (i.e. using Fusion 360 and latest Carbide Motion) have a more up-to-date solution to my problem (which, unfortunately, is still an issue for me).

Question: I’m very happy with my old Nomad 883, but am getting a consistent scale error: A 1 cm square design results in a 10.15 (X) x 10.30 (Y) mm cut (using either Fusion360, or MeshCAM): Is there a protocol for calibrating the geometrical precision of the Nomad?

Many thanks!

-Peter (In UK lockdown, but well and happy).

The first variable to check is true endmill diameter. Have you put calipers to your endmill? That doesn’t account for the variance between the two axis, but looks like it had the possibility of accounting for all of thre X and half the Y if it is off.

You can also calibrate the steps per mm in the grbl settings. Search the a Shapeoko section for “belt stretch” to get an idea.

1 Like

Short form: I would start by seeing the guide for the Shapeoko. You can use the same technique

Longer: cut samples (circular paths are common, but squares work just as well, really, and the guide linked below is written using three holes), calculate the needed adjustment for each axis, then reset the GRBL steps/mm in the machine controller.

CUT SEVERAL SIZES of test shape. If the error is inconsistent from size to size, the endmill size needs to be compensated.



I will measure and modify GBRL as necessary.


-P :slight_smile:

Write down the existing settings FIRST.

Again, write down the existing settings.

Oh, by the way, before you even begin the process, so you don’t forget, write down the existing settings.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.