Calling all electricians and gcode pros

(Griff ) #1

So, I’ve been working a while cutting and building MrBeaver’s linear Z. The only electrical required was an extension to the wires for the Z stepper. The build is done.

Booted up UGCS (no experience, complete noob) connected to cutter, immediate error, 9. Bummer, shoulda been perfect. Ok, what’s wrong?

Discovered error has to do with homing. But, I attempted to home despite the error, the Z moved…down, then stopped. No movement on XY. OK, the Chinese ball screw is made backwards, haha, just a joke. Google, found the way to reverse Z, sent the code. Rebooted all, still got error but attempted to home anyway and, yippee, Z went up… and stopped.

Remembered (quite a feat when you’re as old as I am) that homing can be disabled, so Google, and homing is disabled.

Rebooted all, error 9, BUT, I could jog in all three axes, in the right directions. Yippee. More progress.

Took a break to take care of some honey do’s.

Then, back at it. Oh crap, now instead of a satisfying “thunk” when I power on all I get is an anemic “click”, the steppers aren’t engaged, I can push the carriage by hand.

I tried connecting with Carbide Motion, got a homing error plus not being able to connect with a limit switch. And, again, the steppers are not engaged.

Hmm, where do I go next.


(Neil Ferreri) #2

Can you post your grbl settings? Send $$
Make sure $1 = 255

(Griff ) #3

Thanks Neil, here you go:

(Neil Ferreri) #4

So you’re connecting to the board fine, but the steppers don’t react now? As in your experience, the steppers should enable as soon as grbl starts.
You have $4 = 1 which inverts the stepper enable pin. Is that intentional? That basically reverses the logic of your stepper enable…default is 0. Unless you modified something with the controller, that should be 0.

(Griff ) #5

I changed the $4 setting to reverse the direction of Z. In the brief time the steppers were working I noted the Z moving opposite to what it should have been

At this point I’m guessing the controller is fried. No magic smoke though. I’ve reached out to Carbide to order another.

(Neil Ferreri) #6

$4 is not the direction invert. It’s the enable invert. Basically if someone had a system where the signal needed to go high instead of low to enable the steppers.
$3 controls the direction invert for all axes.

(Griff ) #7

DOH…just enough to be dangerous! Thanks!

OK, it’s fixed but Z is still reversed. What command do I send to reverse it?

(Neil Ferreri) #8

Great! Glad you didn’t fry anything…I wanna see this new Z in action!
To reverse Z:
You have $3 = 6
Change it to $3 = 2

Reference here

By the way, it’s not easy to fry a driver unless you’re disconnecting or connecting things while powered on (don’t do that)

(Griff ) #9

Ok, Z is now correct.

I rebooted all, now I can move all axes but I get error 5 when I try to home

EDIT. I changed $132 from 78 to 130, turned on hard limits. $H works now :stuck_out_tongue_winking_eye:. I just need to determine what the actual number is.

But I think I need to adjust the steps/mm(?). When I ask Z to jog 10 mm it only moves 2 so off by a factor of 5.

(Scott Conant) #10

Error 5 tells you that homing is not enabled.

Do you have $22=1?

(Neil Ferreri) #11

That’s your $102 value. If you measured the 2mm pretty precisely, change the value to $102 = 200 and then test again.
Expected_distance / actual_distance * current_$102_value = new_$102_value

(William Adams) #12

Error 5 has also been caused by using CM3 with Grbl 1.1

(Griff ) #13

Homing is now enabled. I’ve gone back and forth with that as I grope my way through this UGS experience.

OK, got it. Machine will home now, Z travel is at least in the ball park at 200. Now I just need to learn UGCS,

(Neil Ferreri) #14

What happened to CNCjs?

(Griff ) #15

Well, yeah, that too.

What the hell, I’m 69, I need to challenge this old brain…

(Griff ) #16

But, not right now :grinning:

(Luke) #17

This topic just saved my bacon. After not allot of sleep I was struggling to work out why I could move my axis but the motors had no torque hold. After remembering this I changed my settings. No joy. I then spent another hour testing another board, checking voltages and currents. Still no joy. I then re checked my settings to find I put in 25 not 255… Motors holding again… Fml