Carbide 3D wont display top page (menu)

Usually you can fix this by tweaking settings in your video systems DPI scaling.

I’d suggest just trying the new CC400 build instead: — see: for more information.

Thank you, it didn’t work

Update the video driver if possible, or if using the OEM driver, switch to one from your video card manufacturer.

Please check your DPI scaling and video options.

Also try the Windows compatibility troubleshooter.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.