Carbide Create 413 Toolpath Loop

(Kirk) #1

While trying to create a filleted rectangle lip that was slightly larger than my 1/8 endmill size I tried using a pocket to make the two required passes, and either CC is looping or taking a really long time (I waited 5 minutes), displaying calculating under the toolpath. Loading the c2d file would recreate the problem but I accidentally overwrote it. Changing to outside and inside loops on the two edges also loops on the inner edge (Lid Lip in the attached file).

Also, a couple minor nits. Plunging for the outside cut left a shallow groove in the box side but not sure I can blame that on CC. Trying to add a tool (Toolpath, contour, edit under tool, edit library) always returns “This is a built-in tool that cannot be edited”.

In full disclosure this is being generated for a cheap Genmitsu 3018 Pro since Mrs.Moose doesn’t think our florida home has room a SO3 atm

Kirk

ToolpathOffsetProblem.c2d (62.9 KB)

0 Likes

(William Adams (Carbide 3D)) #2

For adding tools please see: http://docs.carbide3d.com/assembly/carbidecreate/video-tutorials/#custom-tools

If you select a tool before clicking on “Add Tool” the selected tool will be used as a template for the new one.

  • Toolpath
  • Edit Library
  • Add Tool
  • double-click on the new tool to go into edit mode
  • edit as needed
  • Ok
  • close window
0 Likes

(Kirk) #3

It still complains about an uneditable built-in tool, whether I create a new one or try and edit an existing tool and change it’s number to an unused value of 1.

Maybe a Windows permission issue?

0 Likes

(William Adams (Carbide 3D)) #4

The specific sequence is a bit tricky.

Which version of Carbide Create are you using? I just tested CC420 and it worked.

http://carbide3d.com/carbidecreate/unstable

0 Likes

(Kirk) #5

413

Padded to 20 characters by saying it was the latest released version a couple days ago

0 Likes

(Kirk) #6

Installed 420, discovered adding a tool was a user issue after reviewing the video again. I wasn’t selecting newly created tool after clicking add tool and before editing. Whoops. Also learned how to delete all those extra tools I’d made earlier after reducing my slightly undersized endmill to .120". Sorry for wasting your time on that one

The toolpath calculating issue still exists in 420

0 Likes

(William Adams (Carbide 3D)) #7

No problem! Thanks for confirming the toolpath calculating bug — we’ll try to get a developer to look into it.

0 Likes