Carbide Create 527 Beta

We just posted a new beta of CC, build 527. Full details are here: Carbide Create 527 but the highlights are:

  • (NEW) Added new Engrave toolpath to Carbide Create Pro
  • (FIX) Potential crash on new file with tool paths calculating.
  • (FIX) Advanced VCarve Toolpath output is now reduced to a more reasonable tolerance.
  • (FIX) Render locked layers beneath non-locked layers.
  • (FIX) Rare crash in Model Import command.
  • (FIX) Additional output digit in all post processors.

Downloads are at: Carbide Create Beta Downloads

UPDATE: We’re now at Build 530 for bug fixes


Known bug: Certain repositioning moves when pocketing may not fully retract in Z-axis as required, causing gouges in work piece. You are strongly advised to simulate all toolpaths before running a program. This will be fixed in the next build of Create.


The advanced vcarve optimization is great. A street/number sign I made for a friend had the controller a bit choking on the many small steps, but with the 527 beta, the file size is 4x smaller with many redundant gcode lines removed… it’ll cut probably at roughly half the time now.


FYI: On 526: I ran a job that pocketed 180 pockets…smooth, quick and perfect! I’ll load 527 now.


Carbide Create v528 is up:

  • (FIX) Plunge gouge in pocket when zero is at bottom of stock.

V524 on Windows 10, Any idea where my My Single Line fonts (ref 1CAMBam_Stick) fonts went?

Used to work with an earlier version…(Yes, they are installed) Using (Note: V5 on my Mac still shows them.)

Are you moving from 524 to 528 or did you remain on 524 and the font disappeared?

Let me clarify. I went from 464 (had the Single line Fonts) then upgraded to 464, 474, 514, 520 and lastly 524 (I wanted to try the Drilling on 524) and somewhere along the way…the single line fonts just went away.

I’ve been busy cranking out these steel crankshafts (haha see what I did there), and didn’t notice that I wasn’t on the latest version until about an hour ago.

Yes, I should update and recheck…

I’ll finish up this roughing operation today and update to 528 and check if my (installed) fonts return… and then return to let you know.

I hope 528 still has the Drilling Oper…

1 Like

Update: V528 Installed, Font’s re-installed…Single Line Fonts…still not there in the Win10 machine…but there (and working) in V528 Mac

just to make sure
you installed the font for all users (eg system font)

1 Like

Could you send the font (if the license permits) or a link to it (if not) to and we’ll do our best to look into this.


Fonts: Free Download from this site:

That was it!!! Smart a boy! Thanks!

Come to think…I did replace the laptop and must have forgotten that.

1 Like

Hi Richard,

I’d love a copy of those fonts - but if I click on the download I just get a 404 not found error.

Would you be willing to share the file?

That’s why I left it there knowing that single line fonts are very popular and hard to find…

Well I’ll be darn…where did they go…

I have a copy of them in the Shop. I’ll put them in my Google Drive and post a link here in the morning (if I remember…)

I grabbed them earlier this year here


Excellent - thanks, got them!

Build 529 uploaded to Carbide Create Beta Downloads to fix an engraving toolpath bug.


Testing out Build 529, when I click on the Create Text button the application crashes without warning/error.

I’m on Windows 10 64-bit. The crash happens on a fresh document and after clearing out the C:\Users\<username>\AppData\Local\Carbide 3D\ folder.

I upgraded from build 526.
I’ve attached the log file from the AppData\Local folder if that will help at all.

Carbide (487 Bytes)

1 Like

I was able to duplicate that in Windows, as well as in Mac OS X — here’s the crash log from the latter: (23.5 KB)