Carbide Create beta issue

nope the dialogs are all read only
(to be specific, this is for editing a path later, during creation they’re fine)

Are you all on OSX or Windows?

I’m on windows 10 (latest update)

also let me know if you want to see a screen grab now that I’ve figured out how to make those :wink:

1 Like

Well, it would be a waste to not ask for a screenshot then. Can I have one?

1 Like

I tried typing in all elements, only the checkbox for the roughing tool responded

I don’t think this is specific to the c2d file but the file was from Using "Advanced VCarve" in Carbide Create 461 to make Inlays just in case

1 Like

Thanks, I’ll see what I can duplicate here.

not sure if it helps but CC prints

qml: QPointF(12.566, 71.4576)
Update View on Elements Changed
qml: QPointF(50.8268, 34.6973)
qrc:/qml/components/ToolpathListDelegate.qml:161: TypeError: Value is undefined and could not be converted to an object

around this time (not exact since the messages aren’t timestamped obviously)

1 Like

What kind of PC are you on?

I’ve tried this on a pretty recent Intel NUC as well as a Dell Laptop that’s older

I’m getting the same results on my nuc pc running windows 10. It seems to be any advanced v carve tool path, not specific to one file. If I edit the tool path to include the Roughing out with another tool, it does recalculate the path. So it looks to me like it’s just an issue with the text boxes. Thank you for looking into this more.

Can you try 463 from and tell me if it’s any different?

We can’t duplicate the problem so the potential fixes are just a bunch of guesses right now.

1 Like

sorry but still the same behavior

Figured out a useful piece of info! And a workaround!

Linked a screen capture below of a video where I show that when you try to edit an advanced vcarve, it just won’t let you type in the box. However, you can highlight it and right click and copy or paste. I found that if I pasted anything into the text box, it seems to reset it and then allows you to type in new values. keyboard shortcuts don’t work, you must right click to copy and paste. but you can copy/paste the same value to unlock the field.
Just confirmed this issue and workaround are present in 462 and 463.

1 Like

Can you grab 463 and try again- we just made another change without changing the build number.

one more breadcrumb clue
if I am in the state where it’s read only
if I then go into the “edit” for the V bit, I can edit fields in the screen that shows up there-

but tada, after that, I can edit fields in the main screen again!

(and I’ll re-grab 463)

latest 463 still the same. The clue from @bstucker87 about, once you paste into the field it becomes editable is real, I see it too
(disregard my previous comment…,. I was also doing cut/past experiments. Note that the screen that pops up for the “Edit” for the V bit is also read only)

also once it gets unstuck after a paste… the next edit makes it all read only again


yup, I made the video with 461, but I tried both 462 and 463 and get the same behavior.

Now I can duplicate it looking at your video. If I double click the operation I can edit it. If I right click and then click “Edit Operation” I cannot edit the dialog. Now we can get this fixed.


Glad to hear it! I have enough programming experience to attempt to troubleshoot. Or that’s what I tell myself when I’m just clicking around randomly hoping something will work. haha