Carbide Create crashes following installation.?

(William Adams) #12

All that you can do is provide the specifics of your system and the crash logs to support@carbide3d.com — if they can manage to duplicate it, or get more reports of such difficulties, then maybe they can fix it. It might be possible to pursue it with the folks who create the QT libraries — they have a lot more users, so might have more data on this. It would help if we knew which specific QT version is being used.

The other possibility is that there’s something in your Windows installation which is causing this difficulty — that’s a deep rabbit hole, and a lot of effort, but if you were inclined, you could start with a fresh install of Windows and see if the problem persists.

Computing hardware is so cheap these days, it’s practically disposable, and one could pretty easily pick up a suitable new computer while shopping for groceries (seriously, at the local Wal-Mart, see if they have an RCA Cambio tablet). The community has noted some known working configurations at: http://www.shapeoko.com/wiki/index.php/Carbide_Motion_Machine_Control_Software#Known_working_configurations — might want to just grab something listed there, or similar hardware.

Alternately, some users have plugged in Raspberry Pi computers and run the machines headless using remote access. I’ve been tempted to try replacing my controller w/ a Smoothieboard and to use a Viki 2 LCD.

0 Likes

(William Adams) #13

Please note that even if you can’t get Carbide Create/Motion to run, you’re not out of luck — the opensource software runs on pretty much everything, and used to be the default. Please see: http://www.shapeoko.com/wiki/index.php/Software

0 Likes

(Bill Smith) #14

Hey Will,

Thanks for the note.

I’ve been planning to purchase a pretty hefty new computer ($1000 range) with all the bells and whistles and use my perfectly functioning personal computer to control the XXL. Looks like that plan is out the window. Never dreamed I’d have to purchase a third computer in order to run a simple program like Carbide Create.

Long story short, On the way to work today I stopped by the local computer repair shop an picked up a new used/refurbished Dell laptop for $179.00. Now I’ll have to put the purchase of the new system on hold for a while because I’m certainly not going to throw away my good computer.

Anyway… brought the Dell home, downloaded CC & CM. They both downloaded and installed as expected. CM seems to run OK, but without a router connected it can’t be tested.

CC opens usually. Occasionally with just an empty window with a title that requires a close and rerun. Then it will crash occasionally when selecting “Material” a solid black box appears instead of the choices then it crashes.

Then it will crash occasionally when I try to select “Machine”… again a solid black box in place of the choices.

It will also “Freeze” frequently after clicking Show Simulation while the Carbide Logo files is on the screen, especially when “Aluminum” is visible in “Toolpath Simulation”. Funny thing is… even in the frozen state and none of the buttons are functioning… If you select “Open” at the top of the screen, a “Save as” dialog appears… Go figure.

Anyway, so far my experience with this POS (Piece of Software) has been a joke and I’m not laughing.

Thanks for your help. It’s greatly appreciated.

Bill

0 Likes

(William Adams) #15

Please share the specifics of your system with support@carbide3d.com — if they can replicate the environment and your difficulties, then they can try to fix them.

If you need any help w/ any of the opensource software, let us know and we’ll do our best!

0 Likes

(Bill Smith) #16

Thanks Will,

I did reply to one of their emails asking if they would read this post where I included the System and Display information for my system. I didn’t get a reply.

Guess I’ll have to send that info direct.

0 Likes

(peter murad) #17

I also had this problem. I did the following:
Changed video settings. This did not fix it.
Installed the QT development software. This did not fix it.
Updated Microsoft Drivers. This did not fix it.

When to the Dell website and ran their driver update tool. This downloaded and updated all my Dell drivers for my computer.

THIS FIXED IT!

3 Likes

(Bill Smith) #18

Thanks for the note Peter.

This computer is a completely reconditioned Dell Inspiron. I guess it was probably a trade-in at the local computer repair shop. It was taken down to basically a bare disk and complete Windows 7 reinstall with all necessary drivers. It was completely bare of software other than Windows, IE and Live Mail. In that state I installed CC and CM.

I can open CC four maybe five times in a row and get nothing but an empty white window with Carbide Create in the title line. I have to close the window as nothing happens after that.

Next time… it may open and look perfectly normal. But then, when selecting the material for the job, the normal choice drop-down shows up as a solid black box and the program crashes with a Carbide Create has stopped working message.

Next time… it may open and look perfectly normal. But then, after clearing the screen of the Carbide Create drawing, then drawing a square on the screen and selecting tool path, I select the show simulation and the “crawler” window blips bye empty and the program freezes.

I believe, in the 100 times I’ve attempted to use the program I’ve been successful making it to Save Gcode and Save File maybe 3 times.

CM will load normally most of the time and look like it might work if there was a router attached, but then a couple seconds later it crashes with the Stopped Working message too.

Anyway… I’m going to give your idea a try. I’ll post the results.

Thanks for your interest and suggestion.

Bill

0 Likes

(Bill Smith) #19

Hey Peter,

Took the computer to the Dell site and ran their driver search and update routine. Found drivers for flashing the BIOS, Chipset, Network, Audio and Video. Downloaded, installed and ran each of them. Rebooted after the BIOS flash and Chipset update as instructed. Uninstalled and reinstalled CC.

Results… CC won’t even open now! Double click Desktop shortcut… nothing. Right click shortcut and select Run… nothing. Go to folder containing the .exe and double click that… nothing.

Wonderful!!

I have now tested CC on three different computers and it still won’t run properly.

Thanks for the information. It was worth a try.

Bill

0 Likes

(peter murad) #20

Hmm…very upsetting…I am very sorry that my suggestion lead you to a even worse outcome. I work in IT and deal with this type of stuff often. Do you mind if I ask you a couple of more questions and we try a couple of more options? I don’t mean to be nosey, but it bothers me that it doesn’t work when it should.

One thing that I notices is that CC wont work if you change the Video setting from High color ( 32 bit ) to low or 16 bit color. What is the color setting of your video card? Is it using 16 bit?

Also, what model Inspiron are you using?

And did you try installing the complete QT library? ( Although this did not solve my problem, it had been suggested in another post)

1 Like

(William Adams) #21

Yeah. While I hate to go down that road, I almost wonder if in addition to the list of known working configurations we might not have to add a list of known problem machines. Alternately, a couple of the 3D printer companies have started just bundling a tablet — perhaps that would be an option here?

I was able to drive my machine from both an Asus Vivotab Note 8 and a Toshiba Encore 2 Write 10 — the Note 8 has a less-expensive variant, the Asus Vivotab 8 (no Wacom digitizer) — so we should be able to expand that list some.

The video driver setting angle is a good one, and it’d be great if we could add some video driver setting minimums to the system requirements.

0 Likes

(Bill Smith) #22

Hey Peter,

As best I can here are the answers to your questions…

According to the System Information on the Dell… Bits/Pixel is set to 32 currently
The Resolution for the 15" screen is set to 1366 x 768

This is a Dell Inspiron 1440 - 4GB Ram - x64 based
Pentium® Dual-Core CPU T4200 @ 2.00GHz, 2000 Mhz, 2 Core(s)

As to the QT Library… Have to admit that I haven’t got a clue what you’re referring to. :grimacing:

If you can enlighten me, I’ll certainly give it a shot.

Thanks again. Greatly appreciated.

Bill

0 Likes

(William Adams) #23

QT is a programming library / API / graphical toolkit which is used to write many opensource apps, as well as a number of cross-platform commercial apps.

0 Likes

(Bill Smith) #24

Hey Will,

As to the QT Library…

I don’t know where I would find it/them nor how I would go about installing it/them or what to do after I did install. :stuck_out_tongue_closed_eyes:

What do those for whom CC works use if it’s not part of CC.

BTW here’s a screen shot of what I get when I attempt to load CC.

Thanks

0 Likes

(Bill Smith) #25

Hey Peter,

I set the screen for 16 color and uninstalled, reinstalled and there was no change other than the usual black empty window with the Carbide Create Title.

I posted a screen shot in response to Will Adams reply.

Thanks

Guess I’m out $180 for the Dell.

Bill

0 Likes

(Mark Walker) #26

I’m pretty sure that a copy of the QT libraries is included in the CC installer. Some folks may have been able to fix their problem by installing a new set (he mentioned development kit), but my guess is that it resolves a QT version conflict on the machine. Since you recently installed fresh Windows (that’s right, right?), there shouldn’t be another version of QT lying around to conflict.

It does look like QT is having a hard time with your display driver. Dell (in my humble opinion) is often very slow (as in leaves older hardware without updates forever even if the part maker has provided updates). In this case, it’s probably an Intel display driver. I wonder if you’d be able to get a newer driver straight from Intel. (In the past when I’ve done that, it’s been a bit of an “expert mode” maneuver because they really want you to go through Dell.)

1 Like

(Mark Walker) #27

If it has the Intel GM45 chipset, then I think the 64-bit display driver is here: https://downloadcenter.intel.com/download/22166

And the chipset drivers are here:
https://downloadcenter.intel.com/product/35509/Mobile-Intel-GM45-Express-Chipset

1 Like

(Bill Smith) #28

Hey Mark,

I can’t thank you enough for staying with me on this problem. Will Adams sent me a nice note this evening in response to an email I sent to Apollo. In response to the mention of “QT Libraries” I sent the following…

If the postings regarding QT Libraries is related to the Microsoft C++ Redistributable (x86) or (x64)… My everyday laptop, the one I wanted to use in the first place, has a total of 10 of them on my system. CC installs the 2013 version, but I have four 2005, three 2008, one 2012 and one 2015 versions as well. Don’t know if that’s good or bad or even related to my problem??? However, the new used Dell with the new Windows installation has only the 2013 version installed by CC

I don’t recall if you posted before or after I replied to someone that I went to the Dell site and ran their driver search and replace routine. It flashed the BIOS, updated the chipset, audio and video drivers. So I would think everything should be current.

As to your earlier post… the Dell does have the Mobile Intel® 4 Series Express Chipset Family and System Information reports…
Installed Drivers igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Driver Version 8.15.10.1994

I don’t know if any of this makes sense to you, but I welcome any comments or suggestions.

BTW… I just finished my hookups tonight and will be doing the “squaring up” tomorrow morning. I have a friend who has an original Shapeoko and he is bringing over his laptop with CM and CC. We’re gonna give my machine a test shot tomorrow afternoon.

A million thanks,
Bill

0 Likes

(Mark Walker) #29

I think it’s possible that the Dell search and destroy didn’t give you the latest drivers actually. Dell is often 2 years or more behind Intel in delivering the same driver. It may not help, but in your shoes, I’d try the latest Intel driver. From your information, I think this is the right one: https://downloadcenter.intel.com/download/22165/Intel-Graphics-Media-Accelerator-Driver-Windows-7-Windows-Vista-exe-

Of course, the last time Intel released it was 11/16/2012, so perhaps Dell is caught up after all. It’s hard to tell from the system info because they’ve got a few different numbering systems (booo). The link above is for 15.17.19.2869. I think the part that is comparable is the last four digits and since 2869 > 1994, I think the link I gave is newer than what Dell is offering according to this note from Intel: http://www.intel.com/content/www/us/en/support/graphics-drivers/000005654.html

1 Like

Carbide Motion Crash
(Bill Smith) #30

Hey Mark,

Thanks for the note. My Dell has the Mobile Intel® 4 Series Express Chipset Family. I tried the link in your note to the “Download Center”. My chipset wasn’t listed listed among the list of chipsets. I ran the .exe anyway and received a message that my machine “does not meet the requirements” for that driver.

The details of the “crash” message says the failing module is ig4icd32.dll. My System Information file shows that ig4icd32.dll is one of the Mobile 4 Series Chipset drivers on the Dell. The Dell update site is reporting that I have the latest version. ???

I also checked and the only Microsoft Redistributables are the 2013 versions installed by CC/CM. My HP has 10 different ones with varying version and year numbers.

I don’t know if any of this is of use to you, but I thought I’d let you see the info about the system.

I understand how difficult this type of problem is to locate and “cure”, so don’t lose sleep over it. Will Adams has sent me some information on possibly using some Open Source software along with the Universal G-Code Sender. I’m going to spend some time looking at my problem from that angle. Got a lotta reading to do. :fearful:

Thanks again
Bill

1 Like

(Patrick) #31

Hey Bill, hope you’ve been able to find a suitable solution for your setup. I was in the exact same boat…older computer (one that I custom built back in 2009, but still a workhorse)…and was getting the exact same errors as you. I think it boils down to the video technology at the time, specifically the G41/G43/G45 chipset. I have a G41-based motherboard, and it’s always had a problem with the available Intel GMA drivers…only a very specific one from the motherboard manufacturer ever worked…anything direct from Intel would cause the HDMI/DVI ports to not work.

Anyway, as noted, exact same error messages, exact same problem. Same OS, similar Core 2 Duo, same Intel 4 chipset. All boiled down to the video drivers. If I changed the driver setting to 16-bit, I could get the blank screens; at 32-bit, the crashes.

I don’t think you have much of an option with the laptops, but my solution was to get a new video card.

1 Like