Carbide create crashing

I have been trying to open the file for a threaded wasteboard and carbide create crashes every time after about 10 seconds. It is from @myerswoodshop so I am assuming the file is fine and it is just my machine. I have been able to open and slightly tweak hos other files for cam clamps and wasteboard flattening, it is only this one giving me issues. Help? I have added the file and the machine I am using.

myers_woodshop_wasteboard_v3.c2d (257.7 KB)

Seems like decent computer specs, nothing stands out to me.

  1. Make sure you have the latest bits:
  2. Make sure you have Visual C++ 2013 Redistributable (x86) installed: (Repair installation if you do) - the CC installer should have installed this automatically.

I was able to open the wasteboard c2d file on both my macOS and Windows computers, I did notice CC became unresponsive within that 10 second timeframe you described, however it recovered after waiting a minute or two. If you try to click or interactive with the CC app while it is unresponsive, sometimes Windows will treat that as you are expecting it to respond and bring up a dialog to ask if you want to wait or kill it, just leave it be for a few moments if that is the case.


Please try the new beta:

My Samsung Galaxy Book 12 has similar specifications (but due to the stylus crippling of Fall Creators Update I’ve reverted to 1703 twice now) and it opened fine.

If that doesn’t help, let us know and we’ll work up step-by-step instructions for re-drawing it here.

1 Like

I’m not sure if its the limitations of carbide create, but even on my very powerful computers, it still “hangs” when calculating toolpaths. It’s doing it in the background…but if you want a few minutes (or longer for less powerful computers) it will eventually “catch up” and work.


Thanks for all the help gentlemen, I was just too impatient. I got the file to open and you’re right, the trick is just to sit for a minute or 2 once it starts to not respond.


I wish that I could get the same result as you. Been trying to load up an .SVG file and after it loads, to save it as a .c2d file. After ≈ 60 seconds, crash ‘n’ burn. I get a file with Ø bytes on my drive and crashed Carbide Create. Tried saving with/without toolpaths, grouped/ungrouped and same stuff…different day.

Back to head scratching…

Send the file in to us at or post it here and we’ll do our best to look at it.

1 Like

I would not scratch my head for too long if I were you, it’s just a fact that CC does not like files with a (very) large number of objects, my guess is memory management code is sub-optimal.

Back in the day I hit this limit twice, first doing this:

and later trying to load the DXF for the “Aztec Calendar”…it brought CC to its knees. This is when I decided to switch to V-Carve, and it handles the same big file easily.

CC is a GREAT tool, but it has its limits, and this is one of them…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.