Carbide Create doesn't open

I can’t open the app anymore. I already uninstall and reinstall. I don’t know what to do. Can you help me about it? I use Windows10

Do you get an error message?

Have you tried the standard techniques:

  • reboot
  • check for updates
  • shutdown
  • restart
  • create new user account w/ admin privileges
  • install app in new account

If that doesn’t work, contact support@carbide3d.com (and let them know that you tried those things).

It is likely you are 64 bit windows but check if you are 32 bit. 64 bit apps wont run on 32 bit os. Also try right click on install icon and choose install for all users.

The lack of memory may be a cause, have you added any programs to the computer, what vintage is it? Your processor may not be compatible. Is the file path to the software, perhaps you changed drives or storage locations.

One thing to try is right click on the app. and select run as administrator.

1 Like

Did it work before and quit, or has it never worked? Have you changed anything recently?

1 Like