Carbide Create not starting on Windows [Solved]

I keep getting “The program can’t start because MSVCP120.dll is missing from your computer. Try reinstalling the program to fix this problem”

I reinstalled and restarted but still get the same message.

I tried installing the latest C++ and restarted and still get the same message.


I’m running Windows 7, 64bit.

When you install Carbide Create and Carbide Motion, they will launch a Microsoft installer with the correct 2012 C++ Runtime. If you do anything to block this installer then you’ll get the “missing DLL” error. Common causes are:

  • Canceling the MS installer when it launches
  • Having some kind of virus/malware scanner running that interferes
  • Having some permissions problem that keeps it from running

When installing Carbide Create:

  • Be sure that you don’t click cancel or shut down any popups from the installer
  • Try running as an administrator to make sure permissions aren’t a problem.


I had to install the x86 version of the v++ program. I was trying to install the x64 since I have a 64bit version of Windows but apparently that wasn’t the right path. Called Carbide support and they pointed me to the FAQ that showed how to solve it. Thanks!

1 Like

Had the same problem. Solved it by also installing the c++ 2013 redistributable x86.

Thanks for the help.