Carbide Create Tool Library Crashing?

I just finished assembling/setting up my Shapeoko XXL and created a design for my first project in Carbide Create. I’m trying to add my toolpaths and CC keeps crashing when I click “edit library” to add my bits. Currently using Mac OS. I have a MacBook as well as a Mac Mini and have the same issue on both systems regardless of what CC file I’m editing. I did recently upgrade my OS on both machines to Catalina, which so far has done nothing but cause software issues, so this could be my problem?

Which build of Carbide Create are you trying to use?

Build 433 on both machines

Please try 446:

It uses a new tool library system and has underlying .csv files which may be more tractable (or it may not work at all — let us know how things work out at )

Thanks! I’ll give it a try!

I had the same issue with build 433 on my MacBook Air/MacOS Catalina. I reverted back to build 431 and have had no more crashes while editing tools.

  • Macbook Pro/MacOS Catalina - no issues with build 431(I haven’t tried build 433 on this machine)
  • Mac Mini/MacOS Sierra - no issues with build 433(I haven’t tried build 431 on this machine)
  • I haven’t tried the beta version as suggested by WillAdams on any of my Mac machines.
1 Like

FYI- we found that the design library popup crashed in OSX 10.15 and it appeared to happen deep within the Qt framework that. We think it has to do with the changes to Open GL in OS X 10.15 and it wouldn’t surprise me if that was the same crash you’re seeing.

As Will pointed to, we’re moving away from that tool library anyway in the betas and we’re in the middle of upgrading to a newer version of Qt that seems to fix the problem for the design library crash. We should have a new release next week.

1 Like

Thanks for everyone’s help! I’ve been using the beta version and it’s working well so far :slight_smile:

1 Like

I found this thread after updating to Catalina and the Editing Tool crashed 433. I downloaded the 466 version and get the following warning and not sure how to circumvent the ‘problem’:’

“Carbide” can’t be opened because Apple cannot check it for malicious software.

This software needs to be updated. Contact the developer for more information.

Firefox downloaded this file today at 5:23 PM from

What is the fix? Thanks

Please see:

Thanks. Just found this too:

The new tool format looks interesting. Thanks!