Carbide Create what am I not doing right?

I feel like I’m missing something. In Inkscape, none of the nodes are showing as unjoined. But it still comes out incomplete in Carbide Create.

if I connect the unjoined nodes in Create, then go to create a contour toolpath I can only select the no offset option (I’m not sure if any other options would make more or less sense for something like this but I cannot create a toolpath using other options). the toolpath created winds up like this, dissecting

the design.

Please post the SVG file which you are importing into Carbide Create — glad to look at it.

Okay, when I open that in Inkscape, I get a group of 64 objects. Ungrouping results in 64 paths. What we want is one composite path, with everything properly closed up. Usually I would export this to a .pdf, open that in Macromedia Freehand, delete the small slot indicator lines, select all, join, Modify | Alter Path | Correct Direction and be done (save for exporting back to a .pdf, opening that in Inkscape, and re-saving as an SVG).

Instead, we:

  • open the file in Inkscape
  • ungroup
  • zoom in one each corner and delete the extraneous slot indicator lines
  • select all
  • Path | Combine resulting in a path of 174 nodes
  • try importing, and determine that the file doesn’t import properly — some lines are missing — usually this is caused by duplicated / stacked geometry. Looking at the file we can see that some lines are darker than others — select each of those and delete, revealing a duplicate underneath — repeat until all such duplicates are identified and removed
  • select all the small, already closed objects and move them to a separate layer on top for easier manipulation — this is an awkward burlesque in Inkscape of selection and invoking the same menu command over, and over again — not much better in Adobe Illustrator
  • note that if you select all the objects which ought to make up the perimeter and do to Path | Combine, then fill the path, you will get an appearance which alludes to the incorrect import

Laboriously select each component, use the pen tool to connect it to the next, reverse path direction as needed, until finally one arrives at a shape which is a composite, closed path of 115 nodes.

quad.c2d (833.2 KB)

1 Like

Thanks. I think I’m getting it. Inkspace is a new learning curve I wasn’t expecting. Still tinkering around with this.

I feel like I’m making progress, at least with being able to get a vector file imported into Create. Should I be concerned the simulation is turning out like this?


Verify it by:

  • exporting to .egc
  • starting Carbide Motion and connecting to the machine
  • open the .egc and extract the plain-text version of the G-code
  • save that into a file
  • use some other previewing program to verify the file

It looks to me as if your source file isn’t closed around the perimeter — please export it to a .svg and open that in Inkscape and compare that to the file which I provided above — as I noted, you need to get down to a single closed path for each perimeter, and it’s best if everything is combined into a single composite path so as to ensure that the winding is correct.

you made your design within F360. Why don’t you use the integrated CAM to generate the tool path?


I guess I’m getting lost in adding layers, connecting paths, and how to fill the design once paths are combined and closed.

I’m still new and trying to learn too much at once. I didn’t realize this would be an option. I’ve also been putting some time into learning FreeCAD, but found Fusion to be a bit more intuitive for me. If I can use a CAM export feature in either to generate G Code (maybe G Code is wrong here and generate the tootlpath is the correct phrasing), or be able to export to something I can use in Carbide Create then that would be awesome. I feel like what I’d like to do is pretty basic, and if I could figure out an equally basic and efficient workflow… that would be great!

Hey Austin,

I’d stick with Fusion to generate your tool paths. You’ll need to make sure your feeds & speeds are correct, but I’ve found it’s much easier that jumping back to Carbide Create. You can also simulate the machining process to ensure everything looks correct…then easily jump back to adjust your model if needed.

1 Like

nice. I’ll have to try out the simulation stuff this evening. thanks for the tips!

I have seen MANY instances where Carbide Create does NOT show all of the lines that will be cut in it’s “simulation”. I have just gotten to the point that I don’t look at it, as long as I can see that the toolpath is cutting where it is suppose to then I’m good… This is especially true of shallow cuts for whatever reason.


Still having troubles trying to get my Shapeoko3 to run a tool path from Fusion360. At first I was running into the Y axis limiting out at the start of a job. I reversed the origin on my model in F360, this seems to have corrected the Y axis limiting.

If I do not set zero at the height of my stock material and start the program, it will go through the motions of a trace tool path. If I set zero at the stock material, I get a limit switch error and the job stops. I’m guessing its limiting on the Z axis, as its nowhere near the X or Y limits.

I just want to be able to start using this thing.

Perhaps something here helps?

What was wrong with the SVG files which we worked up for you?

Hi @Austin913 - What post processor are you using when saving your toolpaths out of Fusion 360? I’ve been using this one from @Strooom successfully for a while: A better Fusion360 - GRBL PostProcessor

Also, in your setup, what do you have selected for WCS? Someone can correct me on this, and probably explain it better, but I always set that from ‘0’ to ‘1’ (you can find this on the third and final tab in Setup). Also make sure there are no G28’s called out in your g-code.

I’ll read through the link. thanks.

Nothing in particular was wrong with the SVG files, but I never tried them. The prospect of designing and creating tool paths in Fusion appealed to me… being able to use one software suite.

I’m using the carbide3d.cps in post.

I left the WCS at default

screen grab of my setup. trying to get a trace tool path set up (the outline contour of the model) to run successfully before adding more tool paths to mill out the holes and slots in my model.

thanks guys!

I would highly recommend trying a few different post processors. I had to experiment with that a bit before I stumbled on the secret sauce, so to speak. Try the post I mentioned above with WCS set to 1 (the probe WCS will also update to a 1, which is fine).

Do you have limit switches setup and/or are you homing before each job?

Another thing to check is that there aren’t any large Z moves in the positive direction (up) at the start of your g-code file. The machine is dumb and just doing what it’s told, so there’s likely something right there near the top that’s creating the behavior you described. Feel free to post the first 100 lines or so of the file and we can probably spot the issue for you.

yes, I have limit switches. I home and set zero prior to loading a project and running the job.