Carbide Motion App Opens with Blank Screen

I just received my Shapeoko 3 and I’m try to jog the motors but the application opens with just a blank white screen. It did this on my other PC as well but I assumed it was just because at the time, I didn’t have the Shapeoko so it couldn’t connect. I can see the Shapeoko in Devices and it says its on Comm4. I’ve also tried 2 USB cables - they both with kick the motors when you plug it in but that’s it.

I’m running Windows 8.1 Enterprise x64.

If anyone can point me in the right direction I’d appreciate it!

For more information, I have just tried it on my wife’s macbook and everything works perfectly - I can jog the motors etc.

can you shoot an email to support AT We’ll open a ticket and that way we can better track your issue.

I have just sent one - thanks

I just completely reinstalled Windows 7 on my laptop (home premium 64 bit this time) and it comes up with a blank screen. I can’t possible be the only one with this issue???

Reloaded machine with windows 7 Home premium x86 and it does the same thing with the white screen. I’m certainly not putting vista or windows 8 on so I’m kinda stuck now.

@semmons23, I bought a used laptop with Win7 Pro x86 (clean install from the dealer) and Carbide Motion works fine. Sorry, I can’t imagine what might be working wrong with your setup. Whatever was installed with a virgin Win7 was adequate for the CM install to work.

I just replied to the support ticket but I thought I’d put the info here as well:

When we get this kind of ticket, we usually try to find out the make and model of PC that it’s running on. We’ve seen scrambled graphics on old video cards or outdated drivers, but we’ve never seen a blank window before.


I updated the video driver on 1 PC (Sony Laptop) and it fixed the issue. The desktop PC (Dell Studio) has an ATI Radeon 3450HD 256MB video card and is on the latest driver I can find so that one can’t be fixed. My netbook won’t run the app - it blows up and longs some DLL to the event log.

Thanks for the update @semmons23. I’ve got another trick to try in Carbide Motion to make it more tolerant of a wide variety of OpenGL drivers. I’ll try to get in in the next update.


I’ve been having the same problem. I’d like to use my main machine (a Mac notebook) for doing design work while the Nomad works. However, it’s currently the only machine that can run Carbide Motion for me.

I have a pile of old PCs, and experienced this both on a Lenovo ThinkCentre (running Windows 7) and a Dell Latitude D430 (running a recently freshly installed Windows 8.1 with nothing else on it).

For the Dell, I’ve looked into the OpenGL setup. It’s running a Mobile Intel 945 Express chipset, and the driver supposedly supports OpenGL 1.1.

What are the OpenGL requirements for Carbide Motion? Are there logs I should be looking at to determine what’s going wrong?

Any word on this? I have the same issues Win 7 x64, ATI Mobility X1600. Really old laptop but it partially renders the app I can see and click connect but that is about all it will render. I understand if it is just never going to work or be supported on such old hardware, but it would be nice.

Same problem here. Tried three machines all with Windows 7. Two open a blank screen then send a message that the program has stopped working. The third one just opens with the blank screen. Would appreciate having this fixed soon.

I poster a new beta today to fix the problem. More info is at:


Got my new Z-belt on my Shapeoko yesterday and found this beta today. The fix seems to have worked, haven’t tried a project yet, but everything displays ok and I can jog it. Thanks!