Carbide motion build 563 issue with Shapeoko 4 on intel chip mac

Hey, just got my shapeoko 4, put it together with my son and it works great with carbide motion using his m1 chip mac.

However when I tried to run carbide motion using my intel chip mac, software can talk to machine and initialize it, but cannot really jog the machine - the x and y motion can only move a few times, then software start to show “busy” message and machine stopped responding to commands. After this I can still initialize machine, so the controller seems working fine, maybe the commands sent by Carbide motion is having some issues on intel chip mac?

I can repro this issue on another intel chip mac, so unlikely an issue on my laptop.

I’ve been using 563 on an Intel MacBook Pro since it came out and it’s worked well.

Please let us know the specifics of your setup at support@carbide3d.com and we will do our best to look into this w/ you.

Did you resend the machine configuration? My understanding is that information resides on the computer, not the Shapeoko, so it must be resent for each computer.

2 Likes

Thanks William and David, yeah I need to redo the config process and it works now.

Proably not your problem but the default increment is the smallest and some perceive this as not moving.

When you use a new computer you have to send config. This is not so much for the Shapeoko but to configure cm. CM rembers the last config sent so if config has not been sent on new install of CM the defaults are used and not likely your machine is the config used.

1 Like